Citizens walk very slowly


#1

Title: Citizens walk very slowly

Summary: I’m hesitant to report this as a bug since I’m still playing on my mother’s very troubled machine, but I figured I’d just share it anyway with this disclaimer. At any rate, when I loaded the game that I tried for all of two minutes last time (the bug I encountered then was too abrasive to continue gameplay), my citizens walked very slowly. Everything else was at the normal speed, including the walking animation (so they were almost walking in place) and building (once they reached the block they wanted to place, the placement itself was at the normal speed). See attachment.

Steps to reproduce: All I’d done was load my game. I’m afraid my system is involved (see the above disclaimer), so it may be difficult to reproduce on beefier computers.

Attachments:


I got Fraps on this computer just so that I could record this quickly (what do you know, that allows for recording of the music also!). Unfortunately, as soon as the recording started, the fps dropped greatly, with the intermittent freezes seen in the video. Ignore these for the purpose of this bug report; hopefully you’ll still be able to see that the walking animation occurs too often for the amount of spatial progress the focal citizen makes.

Versions and mods: No mods, latest release version in Steam at the time of writing, version 0.1.0 (release 118) according to the title screen.

System information:
OS: Windows 7 Home Premium 64 bits (6.1, build 7601)
Processor: AMD A6-3600 APU with Radeon™ HD Graphics (4 CPUs), ~2.1GHz
Memory: 6144MB RAM
DirectX-version: DirectX 11
Graphics card: AMD Radeon HD 6530D

Darn, I want to play and file reports properly! :frowning:


#2

Not sure if this is the entire answer to your issue, but what is the body stat on your characters? I’ve noticed when playing that a citizen with a body stat of 1 moves significantly slower than with a body stat of 6.


#3

I checked that off video, but it’s not going to be that, because if you saw them go before the recording started (which obviously you couldn’t), they literally went through perhaps five full step animations to traverse a single block. And that’s without even carrying anything. And anyway, they were all much slower than they normally are.

By the way, I forgot to mention earlier that some time into gameplay, it seems that they slowly started to speed up again toward their normal speed, although I hadn’t gotten to the point where they fully reached that. Some seemed to regain speed more rapidly than others.


#4

Quick check: did you load a save from before R118? We did change the speed equation between 114 and 118, so loading a game with the old speed stats results in really slow movement in the new version. On the plus side, zero speed really means no movement, now!

Paging in @Albert.


#5

I’m not exactly sure. I thought I started a new game with the new version, but I may have loaded an older one. Until I come across it again with a game that was definitely started in R118, I’ll assume I’m misremembering and that’s the solution, just because it would be such a big coincidence if that wasn’t it.

However, would it make sense that the citizens start walking less slowly over time the way I described if that really was the issue?

Anyway, thanks for that insight/suggestion :smiley:


#6

Some things make citizens faster: upgraded worker suits, not carrying things, sleeping in beds. But they shouldn’t get faster on their own, no.


#7

Right, of course. Well, it was just in a few minutes; no sleeping, no suits, and there was a bit of a difference I think between carrying and non-carrying, as you would expect, but they just sped up slightly overall.