Citizens stop Building (luac:69)

I seem to get this error on every play through, which so far is about 3 times. Below you can see the error.

“error 1: …th/services/server/build/scaffolding_builder_id.luac:69: assertion failed!
error 2: c++ exception: lua runtime error”

That’s the errors I get when I play. I build a house, but I can never build any more buildings. It’s like they have a certain limit to what they’ll build, then they error. I would upload an image, but as a new user I can not. Here is a Screenshot

I continue to play, and see if it persists. Wonderful game so far though, love the music and the art style.

firstly, welcome to the discourse :smile:

secondly, this should be under the Support-Active Bug category :blush:

What causes your error? Mine seems to occur regularly whenever they place down a door or a window for example, but also seem to occur on a regular interval, sometimes once every 5 or so seconds while they build.

Started playing a new world and it happened again. This time with a different error first, then all the other errors happened. Once again, here’s the image, and yes, all of those are the same error. That’s a lot of errors

I started building the path before the house, even though I had the blueprint for the house done first. I’m still getting use to the game mechanics, so I didn’t realize the path was a separate building. When I went back and finalized the building plans, thats when most of the errors came running. They slowed down around 190 or so… weird.

1 Like

I get that same error

Played some more and after the initial error occurs, every the citizens place an object, such as a door, or a window, a new luac: 69 error occurs. When I hear the little jingle (occurs when something is made), an error soon occurred. These are my findings so far. Will play more… for research.

My workers stopped working on a building and i tried to remove the building and i cant Help?

@Relyss, I’ll let you decide which to merge this with,


1 Like

I just played Stonehearth and tried to add a wall inside a building to seperate rooms (in the design building screen). Well this didn’t really work which is fine and I probably don’t know how to do it correctly. Now I try to delete my design and retry but it is impossible to do so. Also my game crashes and I’m now unable to select anything at all. Also saving the game doesn’t work anymore so I will need to redo everything.

Please look into this.

Thought I’d give it a go, using wood (more of it around) I made a smaller version of you castle and made it in one blueprint. Did hit an issue with the walls above ground floor walls (will post a bug report later).

Note to self, wait until daytime before taking screenshots. Well off to work (real life). Edit: If you read this and are wondering “Is it me or does this reply not match the topic so far?”. You are right, posted this on the wrong topic.

1 Like