Change Party name


Steps to reproduce:

  1. click Combat & Defend
  2. click on Combat Party
  3. Edit Party
  4. Try to change the party name

Expected Results:
Party name changed

Actual Results:
It is not possible to change party name



Version Number and Mods in use:
develop-3107 (x64)

System Information:

Same here, confirmed

I initially did this as part of a pass to both prevent ugly UI (because renaming parties caused the first letter in the party’s font border to be cut off) and to reduce memory of having custom names on items that didn’t need the custom name component. Since there’s only 4 parties, the memory issue isn’t a concern, just the UI ugliness. I will fix the UI ugliness first and then back renaming parties. Sorry for the trouble.

1 Like

Hello! New member here, nice to meet you all. Looking forward for some good time here!

To the business at hand tho. I notice that I cannot change party name at all, and I’m quite sure it was a feature before. Does the way to change the name has changed? Or is it temporarily disabled in current update? I don’t seem to be seeing any notice about this in the changelog (tho I might miss it) hence I’m asking. Thanks!

I don’t remember being able to rename parties…but I’m not 100% positive. I don’t typically rename things in the game so I very well could’ve missed this.

I remember long ago that functionality did exist, but sometimes broke (I guess the party UI in general).

Maybe it was removed the last time they changed the combat UI (with the default 4 parties), or when @yshan was doing performance optimizations on things that can / can’t have custom names.

1 Like

Yeah, I just tried again using the development test build Alpha 18, and I managed to rename my combat party there. It may be an unintentional side effect of new features?

1 Like

Can you rename consistenly, @Haend_Velarius?
I can’t seem to rename parties, maybe it is really broken :confused:

1 Like

Can you be more specific please? What exact version wasn’t working, and which version is. That way the devs can look into what changed and find the bug.

Sure! The version I tested was Alpha V0.18 Dev build 3131. This is the experimental build that gives you warning about bugs in the title screen. Current latest version doesn’t allow party renaming.

@Relyss I could, on the older build. I used to name my combat parties like “City Guard Division” and stuffs. But yeah I can’t rename the parties at all on the current build.


Awesome, thanks for the specifics! If I recall correctly @sdee did a lot of the work for the party system, perhaps she can let us know if this is a bug or intentional? For now, as it worked in the past, I’m moving this to #support:bug-reports.

1 Like

Hi all,
Short Answer: Yes renaming parties is broken
Long Answer: To put it back, I would like to have a redesign of the old renaming system because the UI for it caused the letter borders to not render correctly. So no ETA yet. For now, it is no longer working. Sorry!


Alright, glad that the team is fully aware of this. I suppose it’s just a minor feature and there are more important stuffs to do. Keep up the good work!

There is a topic with this issue :stuck_out_tongue:

1 Like