Can't target biomes or kingdoms through css/less anymore

On previous versions I could do in css/less something like this:
and do custom css styles only when the player had that kingdom selected. The same for biomes.

For example, this is how the archipelago select settlement screen looked on previous versions:

And this is it now:

Because the styles are not being applied.

CEF shows that the elements are getting the css classes just fine:

So for some reason the game is not loading the css from mods?

Perhaps the CSS cascade is overwriting your cas styling? Do you see the css style for the biome in the Styles tab of the chrome debugger when you select that element in the DOM?

No, I was trying to hide the gender buttons for the goblins cause they are not needed and the only display style they had was the default from the browser. The display:hide I added was no where. Same for the select settlement customizations. I must add that the css is the same from before, the file was not touched and was working previously :frowning:

When’s the last time this worked? It’s strange cause the only change we made to these files recently is to add the html element classes to the div elements :thinking:

I’m not sure when it stopped working as I just noticed it now, while trying to customize the goblins.
I think the first time the kingdoms were added in the element classes it worked (first v1.1?), because that was when I got screenshots for the steam workshop.

So this is with the Archipelago biome on workshop? I can take a look

Yes. The version I have in my machine had already a few changes, but nothing was touched related to that

Hey Bruno,

Instead of [class= try using [class~=

Since we have two classes under the class attribute, we need to check if the value is in the space-separated list instead of matching the exact value.

Let me know if it works for you!


Oh, right. That was it. I thought it was also able to target one of many.