Cannot us Wall Grow Tool to build walls on this floorplan shape

537 Latest- Cannot use Wall Grow Tool to build walls on this floorplan shape

Steps to reproduce:

  1. Use the following template to start your building (you will need a bit of room over a flat surface)

1a) Wall Grow Tool vs (23.6 KB)

  1. Once placed attempt to use the Wall Grow tool to build walls.

  2. Observe mouse pointer changes to a red ‘X’, designating no Bueno, when hovering the pointer over the floorplan with the Wall Grow tool selected.

Expected Results:
Walls can be built no matter the users building intent (ie, shape, function)

Actual Results:
Wall Grow tool does not build blueprint walls due to floorplan design

I think there might be a building size limitation/issue. This is the 2nd floorplan design I have tried that would not build walls.

See Above

Version Number and Mods in use:
Latest 537 / None

System Information:

hey there @MickDodge,

just loaded up the template in game, and it appears the floor was made with the slabs tool, not the actual flooring tool, so that could be the reason walls won’t appear.


yep, its as i thought, just made a floor the exact same shape using the flooring tool and walls will “grow” on that, so the case is just that they wont “grow” on slabs…

1 Like

If you look at the style of the floor its actually made with the floor tool, the design doesn’t exist in slabs. (I don’t think?) This might be a something in particular with my game save? Double checking now.

Thanks 8Bit

well i said it was slabs because it sits on the ground instead of in the ground when i place it…make sense?

when you made the floor did you use the first floor or second floor tool?

First floor but let me get you a screen shot of what I intended to cover, I think that is where the issue lies. 2 secs

Here is the original concept space -

Here is how I placed the floor -

You’ll see the 1st floor grow tool selected in the build tab along with the specialty floor design (This design option IS available in slabs though!)

I also started the placement so you can see how that was done.

Is it possible due to the placement of the 1st floor (Not technically in the ground), the game cannot discern this as a first floor and decides to label it as slabs?

Also I have been building 2nd floors with the slab tool all the way through <535 and the Wall Grow tool worked for me. I will recheck on a smaller scale as that might be the issue.

hmm… building it over top of that hole might be causing the problem, but i can’t be certain…

so i’m going to page @not_owen_wilson to see if he can shed some light on this…


You the man 8Bit, thanks boss!

1 Like

Side Note- Placing slabs directly on the ground does not allow you to build walls using the Wall Grow tool, but if you place slabs OVER a wall structure (creating a 2nd floor with slabs), then the Wall Grow tool functions as expected.

Seems irregular that the game makes this distinction.

If you need a bug written on it let me know.