Cannot run Shed


#1

I don’t know if this is worth reporting, but since 24.10.1 and now 24.10.2, Stonehearth Editor won’t load. The process appears, but remains stuck with nothing on the desktop. I learned to use it just yesterday :stuck_out_tongue:


#2

Worked fine for me, although it took a long time to load.
Do you have too many mods? Are they in smod or folders? Bugged mods?


#3

Nope, I’m using it only to read inside of Stonehearth itself and I have that stored in a separate folder. Worked fine before the update.

Gets stuck at around 280 000 kB in processes with no CPU working on it and this is all I get
image


#4

I am getting the same type of error starting yesterday. I can hover over the SHED icon in the taskbar and see the same preview as the picture in the previous response (Amnaa may 26). If you hover it will show a preview window but when you click on it, it doesn’t open and the interior of the preview window goes black (but still has the window frame). I have tried the release that is packed in the most recent SH and I also downloaded a (maybe) more recent version and built it with visual studio and both do the same thing.
Please help?


#5

If you run it in visual studio in debug mode, does it hit any exception?
On first time run it should ask once for the mods folder :thinking:


#6

I get this error:


It asked me once where to load the mod files and it worked. I then moved all my mods to a different folder so I could work between them and move them one at a time into the game folder after the work. Then I did “change mod directory”(?) and reloaded the mods. All that worked fine until I closed the program and tried to reopen it.


#7

Is there a way to try manually telling SHED what the correct file path is (in a config file or something?)


#8

There’s a config file somewhere in the folder, but I don’t know if it ever worked.

If you copy the mods back where they were, does it load? Perhaps it hasn’t saved the new path correctly :thinking:

Certainly moving/deleting stuff while SHED is open and has it loaded is a bad idea.


#9

It does not change anything. Here is the log file also:

[1204/110816:ERROR:tcp_socket_win.cc(341)] bind() returned an error: Only one usage of each socket address (protocol/network address/port) is normally permitted. (0x2740)
[1204/110816:ERROR:devtools_http_handler.cc(220)] Cannot start http server for devtools. Stop devtools.
I am going to remove that install and try rebuilding it with VS


#10

That’s very interesting. Thanks!

It feels like when Stonehearth doesn’t open because the port is already in use.

Make sure you don’t have any SHED-related process running in the background. Perhaps restarting your computer would help, but sounds a bit drastic.


#11

I have restarted like 3 times this morning. I’ll see if maybe I goofed something and it is “starting” when windows starts or something silly.


#12

You might want to try resetting the ports:

netsh advfirewall reset

netsh int ip reset c:\resetlog.txt

netsh winsock reset

It’s the workaround we use for stonehearth when it complains about them.


#13

Sorry, had to go work for a couple of hours. I’m still getting the same errors after doing that. I haven’t re-downloaded and built again in VS… off to do that now!


#14

Still the same errors and invisible SHED
:tired_face:


#15

So after fighting with DOS about who is the administrator of my computer I rebuilt SHED in VS. (release x64). If i run it as administrator from the folder it works. Once. Then back to the invisible SHED. So i built it in debug. It worked. Once. Erase all traces and repeat. Its better than nothing though! SHED is so useful for the dreaded .en file!


#16

If you build it in debug and run it with debugging from visual studio, does it hit any exception when it goes invisible? Or it’s just the error you mentioned above?


#17

I don’t think I have tried that combo yet. Every other way leads to the VS error, or the .log error, depending on where I try to start it from. I’ll try and let you know. ( I have it running so I don’t want to close it!!!)


#18

stupid question maybe, but are you just running the SHED from inside the stonehearth folder? (worked fine for me yesterday…but i intentionally dont point it at the mods folder. but at the steam uploads folder)


#19

You should be able to do both now.


#20

Indeed! But the non mods folder is more practical because then it doesn’t have to load all of base stonehearth :’)