Cannot play with friend, says they are on version 1.2 and I am on version 1.1


#1

Summary: I am on PC, friend is on Mac. When I try to join their multiplayer game, I get a notification saying they are on a different version then me (mine is 1.1, theirs is 1.2). If I click continue, the game crashes. If they try to join me, both our games freeze. Neither of us are opted into a newer version, we are both on the same build according to Steam. Neither of us have any mods installed. Have tried uninstalling and reinstalling for both. Have tried verifying game files for both.

Steps to reproduce:

  1. Friend begins hosting multiplayer session
  2. Invited via Steam (or joined via friends list)
  3. Game freezes after getting notified I’m on version 1.1 and they are version 1.2 and have to close the game (happens if I host as well)

Expected Results: Being able to host or join a game hosted by friend

Actual Results: Game freezes and neither of us can connect to the other

Attachments:

Version Number and Mods in use: My version is 1.1, theirs is (allegedly) 1.2. No mods.

System Information: PC, Win10 attempting to join Mac, OS X 10.9


Windows to Mac Cross Platform Multiplayer?
#2

Hi thanks for the report! I’ll take a look at fixing this.


#3

Can Windows and Mac players connect to each other and play together in multiplayer?
From my experience it appears that the Windows version and Mac version are different.
The Windows version is 1.1.0.937
The Mac version appears to vary from 1.1.0.1000 to 1.2.3.42
Any attempt to connect from Windows to Mac or Mac to windows leads to an error.


#4

I just uploaded a fix for this, please let me know if you can get it to work!