Cannot place any furniture inside buildings

When finishing a building and trying to place e.g. a bed inside, the mouseover displays a red cross and the bed is just being dropped on the floor instead of being built.
Tried many things, nothing worked. Reinstall did not solve the problem.

Steps to reproduce:

  1. Build a building.
  2. Try to place any furniture inside.

Expected Results:
Furniture to be placed at the provided spot and the pointer working as normal.

Actual Results:
Pointer displaying a red cross and the to-be-deployed furniture is instead just dropped on the bottom.



Version Number and Mods in use:

System Information:

assuming you are not using the building editor to add the furniture
check if nothing is in the way (other placed items, walls doors windows, blocks ), the location is reachable, and is enough space available

Adding to what nightlancer said, double check if the building is DONE, if you haven’t finished building it it glitches out if you try to put stuff in it

I managed to make it work. Deleted the entire folder, also lowered all buildings by 1 block into the ground. Setting up furniture now almost always works once the building is finished.

1 Like