Cannot have a combat party size of more than 2

When more than two hearthlings are placed into one combat party, the other members will only attempt to patrol and chase the first two members of the party, they will not eat or fufil any other tasks. To reproduce this you simply have to add at least one hearthling to an existing party of two, the third will only follow the first two, lagging behind and eventually starve

I have tried to add even numbers of hearthlings in hope that it was just an odd number being the issue however this has not fixed it

Release-877 (x64)[M]

Also, the archers are the first two members of the combat party

Does this still happen in r887? We added a fix for this just yesterday.

uh well from what i’m aware the r887 isn’t out yet, well at least it’s not on steam yet

Removed my post from earlier, did not notice your version number in OP which answered my question. Opt in for the latest beta build to fix this issue.

Directions here: Development – Stonehearth

okay will do now thanks

okay thanks a lot it works now


Happy to help! :grinning: