Cannot get game to run after new updates (Lavasoft / Bonjour)

Alrighty then were you able to check if a crash.dmp file was generated? That might provide some insight into the issue.

@bigmacsnackwrap are you able to play in 32bit mode?

Have you tried disabling analytics (uncheking user feedback on the Settings->System tab)?

I have not tried that.

Hey @bigmacsnackwrap, we just noticed that your graphic drivers are outdated, could you try updating them?
(I think these are the ones for your specific model: NVIDIA DRIVERS GeForce Game Ready Driver WHQL, but you can search them manually from here: Download Drivers | NVIDIA ).

Updating the drivers has helped to solve many crashes in the past, and it’s usually the first step we ask to do.

I will try that when I get a chance to get on the computer.

1 Like

Updated Driver. Game did not run.

There is a crash file. How do I upload it?

crash.dmp (172.0 KB)

updated. did not fix problem. Good suggestion though

Thanks for the dump, I think I have located the problem! It appears that Bonjour is being loaded by the game and interfering in some way. Bonjour is one of the known programs that can make the game crash (mdnsNSP.dll). Please try disabling that process and see if it helps.

unistalled bonjour. still didn’t work. will upload crash file for help so far

That would be great, thanks!

Hi @bigmacsnackwrap, you have Lavasoft adware (LavasoftTcpService64.dll) also in the crash.dmp, besides Bonjour.
That one is the most known to make your game crash, please remove it too and tell us if it helps.

Relyss I have unistalled it from my control panel and itsstill there. How do I fully remove it?

It’s tricky to remove sometimes. Searching on the forum I found these steps by Froggy:

Hope it works for you too.

1 Like

Thanks @Relyss, missed that!

Could not find a lavasoft folder. Cleared recycle bin then restarted and ran game. Didn’t work. NO new crash file, idk why. Original crash file says it hasn’t been editied since September 9th.

Assuming you checked C:\Program Files, did you happen to also look in C:\Program Files (x86)?

Edit: If you still cannot locate a lavasoft folder, can you try running Adware Cleaner? This is a simple tool that automatically scans for all forms of adware on your computer. It may help locate all the places lavasoft is hiding. You can download it from here: Downloads - AdwCleaner - ToolsLib.

To use:

  1. Download the program.
  2. Launch the program (no install needed).
  3. Agree to terms of use.
  4. Click scan
  5. Wait for the scan to complete (~5 min)
  6. Click logile
  7. Double click on the most recent log
  8. Save the log somewhere useful (like Desktop)
  9. Close the log and log viewer
  10. Click clean
  11. Accept reboot warning note, your computer will be rebooted after this, make sure to save any open work
  12. Wait for reboot
  13. Relaunch Stonehearth
  14. If it works, great! Please let us know and enjoy the game.
  15. If not, please upload the log file you saved in step 8.
1 Like

Problem Solved. For now atleast. Thank you all for your help and cooperation. I really wnated to give this game a second try. Now I can.

2 Likes

Awesome, so glad to hear it! If you run into any more issues, please don’t hesitate to reach out again.