Can not pile up containers. α18

develop-3085 (x64)[M]
…tonehearth/call_handlers/place_item_call_handler.lua:102: attempt to index local ‘building’ (a nil value)
stack traceback:
[C]: ?
…tonehearth/call_handlers/place_item_call_handler.lua:102: in function <…tonehearth/call_handlers/place_item_call_handler.lua:88>
develop-3085 (x64)[M]
c++ exception: lua runtime error
stack traceback:

Hello,dev team. I have a favor to ask you from japan.I can not use English.
My village is Containers sea now. I pile up containers.So far.α17 can do it. But α18 can not.
Please fix it.

This game is makes me happy.So interesting.I rooting dev teams.

1 Like

Also encountered this.

To reproduce:

  1. place any container on open ground (wait for hearthling to place it)
  2. stack-place another container on it.

wild guess, but I am thinking the new “attach placed furniture to building” thing is causing problems. esp when the parent is not attached to any building.


EDIT: just for record. still exists in develop-3092.

Confirmed, seeing the same issue in A18 3092. I tried to stack two stone chests:

develop-3092 (x64)
…tonehearth/call_handlers/place_item_call_handler.lua:102: attempt to index local ‘building’ (a nil value)
stack traceback:
[C]: ?
…tonehearth/call_handlers/place_item_call_handler.lua:102: in function <…tonehearth/call_handlers/place_item_call_handler.lua:88

develop-3092 (x64)
…tonehearth/call_handlers/place_item_call_handler.lua:180: attempt to index local ‘building’ (a nil value)
stack traceback:
[C]: ?
…tonehearth/call_handlers/place_item_call_handler.lua:180: in function <…tonehearth/call_handlers/place_item_call_handler.lua:162>

When submitting a bug report, pick the bug report category. It should give a basic outline as to what you need to post. Try editing this post and changing the box where it says “uncategorized” to Bug reports, the purple and orange one.

i know that XD but how the bug come into fruition i just dont know how it happens

I dunno either. A good suggestion is to upload a template of whatever building you were building to this thread so they can take a look at it.

i found out about the problem it seems i cant stack the crates for some reason everytime i do it that error message comes up

1 Like

It is not only crates, try to place a garden lantern on a fence.
It worked in the past but now it does not … could be with many more items.


1 Like

just to confirm since it wasn’t obvious from subsequent posts.

This ONLY happens to items not bound to buildings right?

e.g. fence/crates you place on bare terrain.

Nope, I can not place an item on another, but I can place items on structures, buildings, slabs etc.

i meant placing a crate on another crate attached to a building vs a crate on a crate out in the open.
I could have tried it out myself, but it would have to wait after a system migration… (old machine had a cooling issue… and stonehearth makes it worse… lol… liquid cooler is prob badly in need of maintenance/replacement…)

Both does not work for me

Not sure I’m understanding what’s being reported in this topic but I have a similar problem… maybe I need to place this post in its own bug report? Let me know please.

Problem 1 -
When I place down an item (it’s happened with various types but I’ll explain with pear cactus)

  1. Move a pear cactus from the world to my designated farming area.
  2. Place another pear cactus on top (now I have a 2 tier pear cactus, actually looks pretty cool :slight_smile: )
  3. Both pear cactus have prickly pears to be picked
  4. I tell hearthlings to harvest, both cactus now have harvest icon on top
  5. The hearthlings only harvest fruit from bottom cactus. Cactus on top stays with harvest icon and it never gets harvested.

Problem 2 -

  1. Select top pear cactus
  2. tell hearthlings to move the top cactus back to the ground. Hearthlings ignore the request but the cactus stays with the move icon above it for all time

However… they WILL listen if I ask them to move the BOTTOM pear cactus some where else - which then makes the top cactus fall to the ground and then they will harvest/move it.

This has happened with cactus, beds, storage containers.

The beds are completely bugged, even when I ask them to move the bottom bed (so the top bed will fall to the ground) they’re ignoring it completely - not sure whats happening there - if they cant reach it or what.

Similar bug to what’s in this post or should I post it on its own?


I think it’s different but not sure if it’s a bug, or just needs improvement.
In your case hearthlings can’t reach the item on top (have you tried building a ladder next to it besides undeploying?) so until it is reachable it will remain marked to move / harvest.

This bug with the containers here is that there’s an error when you try to place crates on top of another crates.

This can also be due to lack of space around the bed.

I’ll test it out with a ladder and see if that helps. Will post what I find. Thank you kindly.

This is fixed on r650, but you can’t put a crate on top of another using the placement UI, only if you click manually on the crate and the place button on the unit frame.