Buying too many items bug

This happens when I try to buy all of a single item from a vendor.

I’m assuming there is no place for all of the items so it just spits out this error.
Keep smashing those bugs :smiley:

1 Like

does this happen to every item you attempt to buy, or just certain items?

I have tried it with String (I think thats what its called, the stuff that makes the bolts of cloth) and with corn. With the same type of error

are those the only items you attempted to buy? or did you successfully buy other things?

and yes it is called string.

1 Like

(Hey this is Gir (Dan Janes) I can’t do anything with it for 22 hours since I “preformed to many of the same action” (or something like that) so I can’t reply, send messages, or make new topics :frowning: ) I can buy and sell any item. This only happens when I buy all of the same item. Maybe a index out of bounds error. But I would have thought that they they would have stored the items as int numbers. Then when they tried to store more than a certain amount of items in the same block it would give an error. But I don’t know much about C++ or Lua. Just java :smiley:

hmm… okay, also encase your wondering that was an auto flag.

Ya i was wondering how it got flagged a second after me posting… I hope @Gir Will be able to get full member status so I don’t have post like this

hmm… auto flagged again :confused:


I think I got into a nasty scuffle with the auto-flagger once. It didn’t end well for either of us.


Hope you didn’t hurt it too much * begins sarcasm * I wouldn’t want to see anything bad happen to the auto-flagger * end sarcasm *