Buildings templates disappeared after i tried to save a castle into a template

So one day i was designing a giant castle, but it must have gotten bugged because an error message kept popping up. It didn’t crash the game or anything, so i took no notice and constantly closed the report. However, i soon realized that when i tried to save the castle’s template, it hung the game. I then deleted my castle and proceeded to expand my town, but i realized that all my previous building templates were gone, and when i clicked on building templates, the same error message will pop up. I decided to start a new game to see if the problem was with the old one, but to my dismay my building templates were still gone when i tried to build something. I’m not sure what helps but here is the error message.

develop-2972 (x64)
stonehearth/lib/build_util.lua:482: attempt to index local ‘template’ (a nil value)
stack traceback:
[C]: ?
stonehearth/lib/build_util.lua:482: in function 'get_templates_for_kingdom’
stonehearth/call_handlers/build_call_handler.lua:41: in function <stonehearth/call_handlers/build_call_handler.lua:39>

1 Like

5 posts were merged into an existing topic: Building template causes lua error