Building Template cant copy or save designs

Summary: Sooo, I have tried to solve this problem myself, buuut I’m kinda a retard and help is always a… help.

Steps to reproduce:

  1. Play game
  2. Press B or open the building templates manually
  3. Be sad that it didn’t work.

Expected Results: That I could just copy buildings.

Actual Results: Now i have to design building manually every time i want to build something.

Notes: It did’t work in alpha 15 or when i used windows 8 either. I have also tried to reinstall the game by steam


Engine error release-559 (x64)
stonehearth/lib/build_util.lua:482: attempt to index local ‘template’ (a nil value)
stack traceback:
[C]: ?
stonehearth/lib/build_util.lua:482: in function ‘get_templates_for_kingdom’
stonehearth/call_handlers/build_call_handler.lua:41: in function <stonehearth/call_handlers/build_call_handler.lua:39>

release-559 (x64)
c++ exception: lua runtime error
stack traceback:

Version Number and Mods in use: Release-559 (64 bit) Alpha 16

System Information: Windows 10

Hello @Simon_Noval :slight_smile:

Did you have several installations of Stonehearth in your computer? (For example, installed via Humble Bundle and then installed via Steam) This has given problems sometimes to other users.

When you said you reinstalled by Steam, did you manually delete the Stonehearth folder or just cleaned the local files with Steam?

I have only played Stonehearth on steam, and i deleted the game from/by steam aswell. So it should be as if the game was never there.

Hmm… This issue happened mostly to people that installed the Humble Bundle version.

You can try two things. First, verify the integrity of the cache:
1- On Steam, right click Stonehearth on your library.
2- Click on Properties. Click on the Local Files tab.
3- Click on “Verify integrity of the game cache”.

This should detect if there’s some file corrupted or missing and will attempt to fix it. If it doesn’t work, you could try deleting manually the game:
1- Exit completely from Steam.
2- Go to your Steam games folder (typically C:\Program Files(x86)\ Steam\steamapps\common ) and delete the “Stonehearth” folder completely (manually):

3- Reopen Steam and redownload the game ( perhaps it’ll start redownloading automatically).

It’s weird that it wasn’t working for you even in the previous alpha :sweat:

1 Like

Thanks @Relyss . It works perfectly now.
It worked deleting the game manually from my computer itself.

1 Like