Im Having a problem with saving designs

when I go to design a new building it comes up with this error release-707 (x64)
stonehearth/lib/build_util.lua:610: attempt to index local ‘template’ (a nil value)
stack traceback:
[C]: ?
stonehearth/lib/build_util.lua:610: in function 'get_custom_templates’
stonehearth/call_handlers/build_call_handler.lua:44: in function <stonehearth/call_handlers/build_call_handler.lua:43> and also this release-707 (x64)
c++ exception: lua runtime error
stack traceback:

Hey there @Inferno, welcome to the Discourse :smiley:!

Is this affecting all games, or just a specific save? Does the error continue after you save and reload? If so, can you upload the save?

To upload a save, locate the folder in
C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install), zip the individual save’s folder (not the entire saved_games folder), and upload it. If the *.zip is less than 10 MB, feel free to upload it directly to the Discourse. If larger, please upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

It’s happening with all saves and i cant open my latest save and i have tried deleting and redownloading the game and it still wont work

Since it’s happening with all saves, please do upload one or two of the saves for review.

How exactly did you delete the game? From Steam - or another way?

1496876256067.rar (1010.6 KB)

That’s one of my saves and i just deleted locale content on steam

From the error message it looks like one of your templates might be corrupted. You could try deleting your templates folder (C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_objects\stonehearth\building_templates by default). This will delete all your current templates, but you should be able to save new ones. Alternatively, you can try removing each of the templates (the .json files in that folder) one by one until you find the problematic one.

If that works, you can zip up and upload that folder or the specific problematic template, and we might be able to tell how it got corrupted in the first place.


Yes it worked! Thank you so much i have wanted to play for a couples days but that screwed me up. thx