Building gone wrong

so I tried to build a place for my mason, seemed fine, although the pressure of getting it right first time without a remove button to start over was insane :sweat:

But this is how it got built at first

after a lot of undeploying items and pausing the build and starting it again and a few reloads it seems to have started to build somewhat sensibly
but don’t know if it will build properly at all (if I remember will do a finished product post)

I’m just guessing that’s not meant to happen. I have no idea what caused it or fixed it (if it is fixed that is), just thought I would let you know and see if anyone else had this happen.

This is what I meant by started to build it sensibly. I really don’t know if it will actually finish any of the ground floor walls but they got the floor done and started on the walls, so I can hope.

1 Like

this is how it finished. The will not build it more

from inside

Found out what caused this bug
turns out it counted the second floor as a separate building
this is the bottom floor

as you can see its building 63

But the second floor is building 64

although I planned it in one go it has split it into 2 parts then they built the top part first