Building Fences


#1

Summary:
So, making fences manually and placing them in the world works perfectly fin
Yet, going into the builder mode to design a building, and then placing the fences in there, doesn’t quite work. The game will tell you that the Hearthlings can’t figure out how to build it, yet doesn’t give any red blocks.

I figured this out by building a building with fences. Trying it to get the error, and then removing only the fences, where it then worked.

Steps to reproduce:

  1. Design a building
  2. Add Fences
  3. Profit

Expected Results:
The expected result would be either red blocks telling me what can’t be build, or simply the building being build as it should have.

Actual Results:
A message showing that the Hearthling can’t figure out how to build the building, without any red blocks showing which blocks they can’t reach

Version Number and Mods in use:
release-874(x64)[m]


#2

Thanks for the report! This is very annoying :stuck_out_tongue: If anyone has any tips on how to reliably repro this, that would really help


#3

Can confirm that I am also getting this issue, I can’t make fences with the Design Building tool, it says that my Hearthlings do not know how to build them, but none of the pieces are in red. Hopefully this gets fixed soon so I can make properly looking pastures and parks!


#4

I don’t know if this is of any help, but I’m currently running A24 in the stable branch without any mods, and I’ve built a two buildings (a hospital and a stoneworks) that incorporated fencing without any problems. In both cases the fences are external to the buildings themselves, if that makes a difference.


#5

So… if you start a brand new game, cheat a carpenter to level 6, and make houses that are just combinations of 1 fences, 1 endpost and 1 middle, can anyone figure out what combination reliably causes the fences to not build? (I am doing this right now and have not yet found out why some fence+post combinations are being stubborn.)


#6

Well, any for me really. What happened was that I was building a sort of garden with a stone flooring.
So, going from a wall, I placed an endpost, fences, a gate somewhere inbetween, followed by more fences and an endpost, following by the other wall (from the same building), all of this on top of road blocks, which I used as the flooring of my garden. Does that help?


#7

I got this problem trying to make a temporary fence for my pastures.
I made a pasture 50x50 and made a one block high/one block wide slab all around and lined the top of the slab with fences and a gate using the new fence pieces and it wouldn’t build.

Alternatively tried making a stairway 3 blocks wide and lining the sides with fence posts on the walk up which also caused my building to fail.

Nothing turns red at all, if anything can that feature of something turning red be applied to furniture/decorations as well if they are causing error?


#8

Ah. I have made a duplicate post about this with a .gif demonstration.

I can reproduce this reliably with wooden fences and stone fence posts.

Edit: Wrong link! Woops! Posted correct one.


#9

In both the cases you guys appear to be placing fences on top of road or slab blocks. And I think in a demonstration of the new builder on stream, there was a failure when attempting to use fencing on a second floor patio. I wonder if that’s the issue.