Building error message but no red highlighted areas


#1

Summary:
Built new building and tried to have Hearthlings start it. Error message comes up saying that Hearthlings cannot figure figure out building and that highlighted areas are in red. However no areas are coming up red and cant identify what the problem is.

Steps to reproduce:

  1. Build new building or place template
  2. Hit build button

Expected Results:
Hearthlings should commence building
Actual Results:
Error message saying that Hearthlings can’t figure out how to build building and problem areas should be highlighted in red, but no areas highlighted.
Notes:

Attachments:
Tried to upload template but it wont let me.
Version Number and Mods in use:

System Information:


#2

I’ve been getting this a lot too, you can see it right away when you try to build a roof underground (as blocks or floor or whatever) even if it’s mined out.


#3

Also check to make sure if you didnt accidentally place an item in the blocks or walls, I had this happen and couldnt figure out why either, then is saw the little piece of item stuck in the wall, barely visable i erased it and they built the build.

Side note: if an item is on the wall and you shrink it sometime the item is stuck in the wall, only if the items and walls still exist like a corner


#4

I also had that problem. It was caused by fences, placed by the border, in the second floor. As soon as I deleted them from the template the problem disappeared and the building was built.

Have fun, Kyth.


#5

Can we build fences with the fence tool yet? None of the examples given apply to my own experiences yet so hopefully all these examples help the devs.


#6

In my case, it was caused by blocks placed atop a doorway, which weren’t connected to a wall. Sort of an archway. Check if the new structure is absolutely adjecent to another already finished building. The blocks tend to not show up.


#7

I hope you guys aren’t giving examples where you had red blocks, this bug report is very specifically calling attention to the times the errors did not show as red. :slight_smile:


#8

mine didnt show red, it was an item hidden in build somehow. it doesnt highlight items that hide causing the build issue.

one thing i do is to make sure i go over build and look for oddballs that i miss or placed.


#9

The fences are now present in the furniture tab. I don’t know if the “fence tool” will be implemented.

I have had several cases in which unbuildable templates didn’t show the red blocks. The problem is you can’t pin point the problem because it doesn’t show. Finding out about the fences was a test and trial process of eliminating elements,

Have fun, Kyth.


#10

I’m also considering that when there is no “red block” showing the problem might be related to furniture, windows and doors, but this is just speculation.

Have fun, Kyth.


#11

If you guys can post the breaking templates themselves or savegames containing them (assuming the issue isn’t just a case of placement intersecting terrain), it will greatly help us track the issue down.