Building errors

I just started playing a few days ago but have ran into numerous errors while trying to build buildings.

First, I can’t seem to get custom buildings to work at all. Every attempt ends in numerous error messages popping up. Once this starts happening I can’t even edit the building any more and have to abandon.

For example:

I’ve also had lots of problems with the pre-made buildings spawning errors. This poor cottage for 2, for example, fills the screen with error messages as construction progresses. It hasn’t finished building yet, so I’m not sure if they’re a serious problem or just the program carping at me.

Glancing through it seems like lots of people are having somewhat similar issues, so hopefully these errors will be addressed soon. The game is very difficult to play at the moment because of them.

System stats:
Radeon Mobile 5800
Intel i7 2.67 Mghz
Windows 7 64bit

Might as well use this thread for some updates.

  1. The building did eventually finish, but now all new buildings give me the same error.

  2. I finally managed to make a simple custom building, although it oddly has a window it refuses to place. Not sure why, since I have plenty in stock.

  3. New horrible bug: The game has suddenly slowed to a crawl. All residents are showing as idle and at best just sort of sleeping on the ground where they are. Plenty of beds and food, but they seem paralyzed. A few of them occasionally wander a few steps, but that is it. FPS has dropped so that even on 2X speed the game takes a long, long time to get through even a single segment of the moon.

I hope its ok if i add some building errors to this list?

Building a custom building right up against a wall will not allow you to add walls… It just shows the cross when i go over my floor plan…

Did you add this window by editing or was it part of the original design? Had an issue where a window I added later (before the floor was started), got placed a lot later after the rest of the building was complete.

Wall as in an existing building or a cliff?

It was part of the original design.

Was there a second building being built, could be the “I am going to steal that window from that building for this new one” bug, raising it’s head again.

Hmm, yes, but not one that used that type of window.

Thinking about it, I did end up moving that window around a lot as I working on the building design. Maybe it got confused during the design process?

Another question, now the building is complete, enter blueprint mode, is the “ghost” window still there? If so, could be a priority/path finding issue. If not, they will never place it, could of been 2 builders went for the same window for 2 separate window slots, one gets there first takes the window and the second builder now skips/erases the build command. If there was an error message around that time there was the issue.

1 Like

Yeah, it still shows up as a ghost in the design.

I’ve gotten tons of errors on every building regarding scaffolding, so I could easily have missed an error specific to the window.

Thanks for the help on that one.

Last thing then, use ladders, place a manual ladder up to the base of the window. If its a first floor window maybe they can’t reach it.

Hmm, ok, I’ll try that.

I can’t build against a cliff.

It is possible but you have to place ladders manually on the wall facing the cliff, and its literally 1-2 steps at a time as the wall gets built. Here are some I built earlier.


I can’t even place down a call o the floor plan next to the cliff! How do i get manual wall?
Nice houses, btw…


Right use the flooring tool (yellow) make it 1 voxel out from the cliff edge and also straighten the cliff using the mining tool, carefully! Use the auto-wall (red) to surround the floor. In the picture I show how to place the ladders, notice the ghost ladder 2nd from the right placed ready for the 3rd section. Also notice how I spaced the ladders, hearthlings will build 3 voxel width at the top of each ladder. Edit: Forgot, if you use the manual wall placement near a cliff it can crash the game.

Cool! I’ll try that later, thanks!

Btw, noticed on another topic you asked about Manual Walls, by this I mean the grey crenelated wall in the tool window.

Yeah, i sort of figured that out after i asked…

Question: How do you place doors in Manual walls? I tried earlier and the game never gave me an option to put one in place.

While designing the building you need to select the door icon and place it in the wall…