BUGS - 56d14a56-1db5-11e5-ba68-3085a93d830d

Summary: Scaffolding Bug Report, Building problem.

Steps to reproduce:

  1. I have a save game with scaffoldings in place. On various places…
    (on Graves, on other Construction sites, on finished buildings)
  2. Restarting the game caused the error alert to pop at at start

Expected Results: Open Bug Window

Actual Results: Reproduced Bug Window

Does not cause any noticeable Problems with the gameplay.

develop-3023 (x64)…hearth/components/scaffolding/scaffolding_region.lua:412: attempt to index a nil valuestack traceback:
[C]: ?
…hearth/components/scaffolding/scaffolding_region.lua:412: in function ‘_start_erasing’
…hearth/components/scaffolding/scaffolding_region.lua:391: in function ‘_maybe_start_erasing’
…hearth/components/scaffolding/scaffolding_region.lua:196: in function <…hearth/components/scaffolding/scaffolding_region.lua:161>

Some of the Buildings with support Structures will not be built in the correct order. (Bottom to Top)
Like for example a Bridge with Supports as ONE Building Plan: Pavement comes first, after colons or in a mixed fashion.
In my cases often as separated building plans, not planned ahead to finish them first and thus unable to finish them later, due to the “hanging under the structure” space problem where Heartlings can’t build things where the ceiling is to low.


Version Number and Mods in use: Alpha 0.17.0 (3023) vanilla

System Information:
Windows 10 Pro (v1511)
Intel Core i5-3550 CPU @ 4x 3.30 GHz
NVIDIA GeForce GTX 960

The end of the Ogo Campain:

develop-3023 (x64)…aster/controllers/util/campaign_category_manager.lua:122: table index is nilstack traceback:
[C]: ?
…aster/controllers/util/campaign_category_manager.lua:122: in function ‘set_campaign_completed’
…/services/server/game_master/game_master_service.lua:147: in function ‘set_campaign_completed’
…services/server/game_master/controllers/campaign.lua:110: in function ‘finish_arc’
…arth/services/server/game_master/controllers/arc.lua:276: in function ‘_trigger_out_edge’
…arth/services/server/game_master/controllers/arc.lua:256: in function ‘trigger_next_encounter’
…ter/controllers/encounters/dialog_tree_encounter.lua:147: in function ‘_finish_encounter’
…ter/controllers/encounters/dialog_tree_encounter.lua:127: in function <…ter/controllers/encounters/dialog_tree_encounter.lua:110>

Now having the latest update Version of Alpha 17 (Great Work with the Scaffolding btw… :D)

0.17.0 Releas 572

I started a new Game, started a Building and after that an other one and so on… but the first two being huge Wall structures for future deafens they take some time to finish.
Now the Problem is, that I was not so smart the first time around with only one Guard and denying Ogo’s “request” for some goods… in the end the first raiding team killed all my Heartlings and thus I quit and loaded an older save of the game.

Here does the BUG kick in!

Since that Load the two main Buildings for deafens stand still with none of the Heartlings even remotely being interested in finishing either one of them. (All other Buildings before that save had been finished!)
Buildings I started after loading worked as usual, where dug out and build but never again those first two.
Even after reloading and saving… no chance at all.

I can’t “Pause” the building

“Removing” Buildings was never possible in Alpha 17 for me anyway… so that’s out of the question too

Editing the Building by adding something and then “Continuing” didn’t “restart” the building either.

It is completly frozen.

If your building was already in progress (in your save), even if you load it into the newest version of A17 it will not benefit from the new building/scaffolding improvements. You need to place the template anew and start the building over.

If you’re still having problems, please post a link to the template(s) you’re trying to build and we’ll take a look.

I read the Logs,

So yes I know. Fact is the Building was started in a brand new game with the latest update with no other updates in between… and after that story it got stuck, frozen solid…

I started a new Town and for some unknown reason the Heartlings just like that stopped building my very first and only Building half way.

I tried to restart/reload the Game, but the result of it was only, that the not yet (frozen) beds had now been set up. The Building remains frozen stiff.

Something that happened prior to the issue: My Heartlins where hungry/starving and after a while didn’t do a thing any more… just waiting for the newly established farm to produce some food.
After satisfaction, they just stood idle around.

0.17.0 584:

Tried a new Game, a new building… same result:

They first worked hard and fast, no issues and after letting them starve a bit (and reload!) they abandoned building and idled.
Everything else like mining, working their Jobs and all still worked just fine.

0.17.0 593

Still the same issue… somewhere along the way they just like that stop building some buildings just like that.

Maybe it has something to do with building Buildings right next to walls/cliffs which causes the roofs to be “in” those walls/cliffs. That might stop the Building… and it really did, removing the blocks above the section enabled them to finish the roof there but there was still the “2nd Part” of the Building and there was no further progress. Although I had all the needed resources.

Hello @Dragendave :slight_smile:

If you have buildings that are not building you can upload the templates and / or savefiles to this thread: [A16/A17] The buildings my hearthlings will not build (round 2!)

1 Like