Bug report: latest rickety builder items

If you use the new builder to design a house with items in them, then build the house, and then remove the now placed items. If you now try to place other items in the house this is impossible because there are ghost-items in those locations.

Steps to reproduce:

  1. Build House with items
  2. Remove items
  3. Try to put items in old location
  4. Notice ghost items blocking the old location.

Expected Results:
Empty locations read to to accept new items

Actual Results:
Ghost items blocking those locations.



Version Number and Mods in use:
Latest version of the rickety build, tried with and without mods (stonehearth Caffè)

System Information:
Win 7, steam, 64bit, 8gb ram

1 Like

This is because the blueprint hasn’t been updated.

We plan to make the fixtures disappear from the blueprint if you move them after the building has been built.
So hopefully this will get solved soon.
I’m hyped about it even if it’s not implemented yet, because moving items in buildings was really bugged sometimes for the old builder :slightly_smiling_face:


you and me both @ hyped, because as soon as thats possible i can actually swap out beds to comfy beds instead of having to blow up the building to change out the beds X’D

1 Like