[BUG] Object placement

So i was placing some beds for my poor settlers. when i found i had mistakenly placed one bed twice there was no error report or objection to it. however seeing as no one was gonna pick up another bed i decided to place the only unplaced bed left only to find the settler that had picked it up had walked all the way to the edge of the map twitching. Also i placed the unplaced bed right over the ghost of the already placed bed.


placed beds and placed 1 bed twice with both ghosts of the item remaining

waited a few moments to see if a settler would pick up the other bed to place

tasked the remaining bed to be placed over the original ghost

another ghost bed now appears at the edge of the map and a settler carrying it is constantly twitching stuck at the edge of the map.

ordering the stuck settler to move the bed its holding again only creates another ghost.

bug can be replicated:

Take a bed and place it then before it is placed place it again

place a different bed over the ghost of the bed and observe the settler pick up the bed and walk off to the edge of the map

couldn’t find any posts on the matter but i do apologies if this has already been posted

EDIT: attempted to replicate the bug againthe bed was not placed at the edge of the map however the settler still ended up twitching like mad.


Thanks for the report! I believe this is a duplicate of the “ghost object” we’ve had since the beginning.

Similar posts are:

I should probably merge them all into one thread.

Probably, but this one makes such an outstanding glitch…

Sometimes an item is not placed for whatever reason, it leaves the preview of the item where it is going to be, you cannot place a new item on top of this preview and there is also noway to remove the item preview

Steps to reproduce:
I don’t know how its done, it just does it randomly

Expected Results:
The item should be placed where the preview is

Actual Results:
The item is not placed and stays in the stockpile, the preview never goes away

Preview = the transparent thing that shows where the item is going to go
Maybe add a feature where you can click on the preview and cancel the placement to sort out this bug?

Don’t have any unless you want me to

Versions and Mods:
Build 92, no mods

1 Like

Just observed another placement bug…

If you select e.g. a chair and place it into another worker (just press 1 to place it and place it at a location where a worker is sitting / standing), one worker will pick up the item (no matter if it is in the stockpile or already placed) and walk to a “random” location where he gets stuck carrying the item. The more items you select to be placed into another worker, the more workers will pick up the items and walk to the same “random” location.

Bumping as @SteveAdamo linked to this, and it’s still a problem.

Anyway, I’m thinking off-hand about 3 possible solutions for @sdee et al:

  1. Prior to dropping an item off, check to see if the space is occupied. If occupied, find nearest suitable space.

  2. Better initial claiming of spaces in stockpiles so that hearthlings don’t both try to claim the same one.

  3. Periodic checks for anyone carrying things to stockpiles etc to see if they’re aiming for the same space.


I am seeing this crop up again, too. Was trying to place beds in a specific building and it didn’t seem to be working so I tried reloading from before I built the building; rebuilt it and had the same issue.

In only one instance did I get error messages. I am including both in screenshots.

I would literally just build the building and then try and place items in it (I also tried a stockpile and the hearthlings wouldn’t deposit anything in it) and it would refuse to work.

As a note; the door would open seemingly at random and there would be a closed ghost door so I’m not sure this is entirely related?

1 Like

This has been happening to me a lot, even if there is no work to do other than help the farmer, but they seem to not want to pick these items up. I have tried reloading but the same issue applies. I can’t get them to put the item back into storage, nor place the item anywhere else. They can place something else close by or pick up other items, for example, a cobblestone fence, but not the bed I told them to put up.

There should be a way to nuke the preview which cancels the placement, I’m seeing this a lot in one of my current games and it’s highly annoying.