Bug List Alpha 4, Release 0.1.0, Build 127

Number of bugs to report.

After a goblin raiding party came through and killed my trapper, I was unable to view any citizens from this window nor was I able to select someone with the trapper knife token.

Traveler came through requesting 7 fence posts for something. Queued them up with the carpenter and he ended up just placing the finished fences randomly all over the place. When the travel came back through, he didn’t detect that I had made any.

After one bout with a goblin rader, my Footman decided he didn’t want to fight anymore. He wandered aimlessly around and didn’t fend off any goblins on his own or when the town alarm was triggered. He was still happy to collect his upgraded armor. I created another sword token and promoted a different villager who was happy to step in and performed as expected. (Footman in question is checking out the crops while the rest of the village is fighting the invasion.)

The rest of these are just various error messages that popped up while I was playing. Unfortunately I am not sure what I did to produce them.

On a positive note. I was able to upgrade armor, the “Keep X in stock” crafting worked great, and the townsfolk built their little cabin in record time.

Keep up the good work, Team Radiant.

Well I’ve had similar buggs when playing.
Everything works like a charm when playing until one of your guys dies… From that point on it all goes to hell. Sometimes it even just breaks the entire game forceing me to reload the save and play without being to select anything. Or it just corrupts the save and force-closes the game… So I guess ur the lucky one :smiley:

1 Like

thanks for the report @TenaciousTom … hopefully those screenshots will provide Team Radiant with some clues as to the triggers…

and welcome aboard @Sweeck! :smile:

thanks for the confirmations… perhaps there is something to a unit death, and the ensuing crash popups… :+1:

1 Like

Well I’ve been aboard for a long time, just couldn’t be bothered to make an account so I could report something that has been reported a 100 times already :wink:
The reason I did it now is because Tom and me seemed to be the only ones who have encountered that problem and I didn’t want him to feel lonely :smiley:

1 Like

(Turn around)
Every now and then
I get a little bit lonely
And you’re never coming round…


I’ve tested the latest release which was pushed today to my steam account.

I’ve recorded a bunch of bugs.

  • First of all. The UI is flakky. I’ve encountered many circumstances where i open any (!) menu, click on a button, the action is triggered but the menu isn’t removed. After a second I recognizd that he menu isn’t useable. Just the display is still there. The redraw of the whole screen seems to be missing. Even esc or reopen the menu and take another option isn’t a deal. Sometimes buttons doesn’t appear. I’ve had to search around on the screen until the mouseover event is triggered which gives the feedback that this button is visible. For example the overwrite function on the save games.
  • The next thing is the mentioned overwrite function. I’ve got a bunch of savegames of older releases and created a new savegame under the current release. After that I’ve decided to create another savegame and tried to override an outdated savegame (with the info “incompatible”). After that, I’ve closed and restarted Stonehearth. Which leads to the point that the first and the second savegame is missing. The second savegame is there with a correct screenshot as thumbnail, but the new savegame has the flag “Incompatible” and isn’t able to get loaded.
  • Various misc. bugs. Mostly random (sun has set, pet gets trapped, villager sit down to eat a basket of berries) which mostly leads to a commentless crash of the application.

If you need any further informations, just ask. I would be happy to help you with these bugs. I have also videos about the circumstances if you need them for debugging.

Best regards,

Here we go again… People seem too lazy lately, they don’t bother to make separate threads for each bug (le sigh). Anyway, really helpful reports, I’m astonished that there are still calendar errors :open_mouth: (although I don’t really remember if devs mentioned having fixed daybreak bugs :sweat_smile: ).

Hold on, I’ll take this opportunity to test one thing… :neutral_face:


I’d like to report a crash bug. I wanted to make my first silkweed farm. I went into zone management, pressed farm, drug out an area (don’t remember the size, maybe 6x12?), and then in the crop selection window when I pressed the silkweed button to select that crop, the whole application crashed with a C++ runtime error which I forgot to record (sorry!).

I’ll see if I can get it to repeat or not.

Nope. Silkweed farm worked on the next time I played the game… Seems like this is an intermittent bug. My new farm was like 6x6 and I realized my original farm size was much larger than 6x12. Probably like 10 x 30.

A reminder for those who have the time and feel like doing it:

  • Bugs should be reported in separate threads, using the template provided here, to allow testers to comment and update the bug statuses when new releases come.
  • Try to search if the bug has been already reported before making a new topic.
  • Making lists of bugs is not that bad, but in the end is quite disorganized, as people can reply for something posted many posts above and the track of that bug is lost, so it’s not recommended to do that.

Let’s keep the forum as tidy as we can to ease the work of the developers :smiley:

P.S.: Did I sound too forgiving? Should I be more agressive? :confused:

:star: Bug Report Guidelines :star:


Another reminder for bug reporting:

If you click on the error message in the red box, you’ll get a new, dark grey box appearing with lots of detail on the error in question. Maybe not too useful if there’s a dozen or so lines of error, but if it’s just the one then you can probably help Radiant some more by going into it.


Oopsies, sorry about that

Don’t worry, my plan is to organize it a bit better in 1 topic to make it easier, by hopefully constantly updating depending on bug status. Also, is there a way to link replies in the topic or make “Spoiler” tabs?

Thanks :slight_smile:

Do you have any mods attached to your game? Have you tried deleting your old saves? If not, give those a try and then report back, just want to make sure that it’s not because of those issues.

Ok, these should be fixed for the next release. Thanks for the reports!

Can anyone detail steps on how to reproduce these (or any footmen not attacking bugs)? So far, I haven’t had any luck.


I’ve seen a sword-eating footman now. Peaceful mode, leather armour upgrade, sitting down inside a house at a table to eat pumpkin (I think). See post #18 in this thread for a screenshot.

The lua error I saw indicated that the game was looking for a “mob” value in the entity it had just killed and couldn’t find one.

Unfortunatley I haven’t got a .log capture of it


Hopefully the two replies above mine here help :slight_smile: And you’re welcome, thank the community furthermore, for I’ve just been compiling them :stuck_out_tongue:

Keep up the great work with the game, can’t wait until next release :slight_smile:

no… no mods. Just the play stonehearth. But it’s installed since the very first steam release. Even find broken files doesn’t help.

I completely removed stonehearth in the end. After all I reinstalled it (which is the good side in an early access game, the game is installed in minutes. :smile:). This solved the ui bugs. The saves where still broken, even new saves are broken too. This issue could be solved by completely drop the save game folder.

Now the most of the game works like before.

I just noticed that the game just breaks on some day and night changes. This wasn’t a problem in the releases before.

Today I will test Build 134. Hopefully those bugs where killed in it too. :smile: Otherwise, you will hear from me as soon as possible. Thanks for the help. :wink:

Awesome :slight_smile: Well I’ve started a new topic on the R134 bugs I’ve encountered, if you find any in the new release, post them there so I can add them to the list :slight_smile:

Thanks Ionic :smiley: