Blacksmith doesn't get promotion


I have tried promote worker to blacksmith, but after promotion he doesn’t do anything and I can’t open crafters menu. I have tried promote him back to worker and blacksmith again, but result is he just stands around half naked. I am not sure, does one of the mods this problem, so I think someone could help me with it.

Here is error code:

release-761 (x64)[M]
No matching overload found, candidates: luabind::object load_json(lua_State*,std::string const&,bool)
stack traceback:
radiant/modules/common.lua:245: in function ‘report_traceback’
radiant/modules/common.lua:256: in function <radiant/modules/common.lua:250>
[C]: in function ‘load_json’
radiant/modules/resources.lua:33: in function ‘load_json’
…nehearth/services/server/job/job_info_controller.lua:242: in function ‘_build_craftable_recipe_list’
…nehearth/services/server/job/job_info_controller.lua:107: in function ‘activate’
radiant/modules/common.lua:539: in function ‘create_controller’
…earth/services/server/job/player_jobs_controller.lua:48: in function ‘_ensure_job_id’
…earth/services/server/job/player_jobs_controller.lua:77: in function ‘get_job’
stonehearth/services/server/job/job_service.lua:65: in function ‘get_job_info’
stonehearth/components/job/job_component.lua:125: in function ‘get_job_info’
…rver/town/orchestrators/craft_items_orchestrator.lua:17: in function ‘run’
stonehearth/services/server/town/town.lua:539: in function ‘_thread_main’
stonehearth/services/server/threads/thread.lua:273: in function <stonehearth/services/server/threads/thread.lua:270>
[C]: in function ‘xpcall’
radiant/modules/common.lua:265: in function ‘xpcall’
stonehearth/services/server/threads/thread.lua:270: in function ‘f’
radiant/lib/env.lua:15: in function <radiant/lib/env.lua:14>

Version Number and Mods in use:
Mod list

Savefile (7.1 MB)

This one might be tough to find with the mods involved. I’d ask you to disable your mods just to see if he will promote, but I know that doing so will cause a bunch of errors when you load up the game.

Still, if you clear the errors, retry the promotion, then exit out and re-enable the mods, you should at least be able to tell if one of the mods Is causing it, or if it’s the base game. Worth a shot?

Only mod which I didn’t disable was swamp goblins and I got promotion to blacksmith. So problem is not in the base game. Chabonit mod is my latest download, so problem might be on that?

1 Like

Sounds like a likely candidate. If the mod designer is still active, please contact them for assistance directly. As you might expect, Team Stonehearth can only provide support for the base game.