Base_job ignored, defaulting to stonehearth:jobs:worker


In the firefly clan job index, I had this:

	"mixins": "stonehearth:jobs:index",
	"jobs": {
		"swamp_goblins:jobs:worker": {
			"description": "swamp_goblins:jobs:worker"

The game ignored my base job and set the stonehearth default worker instead.

To workaround that, I disabled that worker, like this:

		"stonehearth:jobs:worker": {
			"description": "file(go_away_worker.json)"

With the go_away_worker.json file like this:

	"mixins": "stonehearth:jobs:worker",
	"enabled": false

This worked fine. Until we hit multiplayer. For some reason, the client using Goblins will have the default workers again when the host uses N.A…


Northern alliance defines its own worker (RC doesn’t mention it in their job index). Try changing that one too?

I’m confused that the game ignored your base job. Wasn’t that working before? :thinking:

The other inherited jobs might be actually pointing to “stonehearth:jobs:worker” as their parent, so that would explain why it still appeared… you’re gonna need more mixintos, probably :disappointed_relieved:

Still confusing given that it’s the host who’s using NA :thinking:


But the n.a. is done in their own job index, it does not affect the main one, right? Their “new” worker is something only they have, while I’m importing from the default index.

It worked before (in single player only) when I didn’t imported the default index. But I had to start importing it else the game crashs when you reembark someone that has a job not listed in your kingdom


I wonder if it’s related to the cached job constants in app.js retrieved from the job service :disappointed_relieved:

Can you check in the client which jobs / job index have been loaded somehow?


I’m not sure, I’m yet to test it myself in multiplayer. I got the reports from the workshop comments.

I noticed that rayya also have a modded worker for themselves, like the n.a. it is just changing their clothes.

I printed the mods in order of loading, and noticed that the rayya mod is loaded after the goblin mod. I will try later to add it as dependency so the goblins load after it and see if it makes a difference


So, I got a few things wrong. N.A. was not working even in singleplayer.
For some reason, they got the goblin_worker as the starter job in their trees. I fixed it by setting enabled:false in the goblin job description. Then in the goblin kingdom, that is reverted to enabled again.
In multiplayer, same thing, I enable and disable the goblin_worker based on the kingdom. Seems to work fine now.

Except one thing. The goblins, when in the client (didn’t tested as host yet), even though they have their job trees correct, they start as stonehearth:jobs:worker, at the roster selection screen, even wearing the ascendancy clothes. In game, it is not possible to promote them to actual goblin workers (the action is ignored) and further jobs too. I noticed that changing them through console back to goblin workers fixed it. So I’m going to check at their creation if they have the right job, and if not, manually set it to the correct one. I think this should “fix” it, and make them all playable in multiplayer.