Barely 20fps on Stonehearth

It starts with like 20fps at beginning of the village (having nothing) then, when i build a little village it barely has like 10fps. I have some mods installed for decorations, and some like ACE, and the cloud remover, but i don’t think that’s really what’s causing it.
I have a ‘fairly’ powerful PC, it runs W3 on ultra with easily 60+fps, and stonehearth i think is nowhere near that graphical level, so could this be a CPU problem? Although i don’t think it is because CPU is on like 20% max, so maybe ram? I know mods use ram a lot but i’ve tried it without mods and it’s still the same. I’ve tried re-installing the game also.
It’s so bad that i can’t even pause the game properly, it takes like 5seconds to pause time in-game.

I’ve read some threads here before and i’ve seen that the game doesn’t really have a good code for cpu or something? didn’t really understand much.

Ryzen 5 1600
Radeon RX580 8gb
8gb ram
Windows 10 Pro

well a ryzen 5 1600 should do fine wih this game, the really really low fps is kinda strange though. got any weard antivirus software running? i have heared before that that likes fighting with this game…

but your specs should not be the problem. also is this on a laptop or a pc? (could be a thermal issue if a laptop?)

It’s a PC, and no, i don’t have any anti-virus. The only thing close to an AV is Windows Defender.
I will try to do a fresh re-install again soon, because i really love this game, but the 10fps is really unplayable. It could be RAM i think. It’s using 4gbs but i have 5gb allocated, idk what’s the problem really xd

well the game does have a bit of a memory leak, but if you have 8gb it should run fine. i mean more is better but i used to have a good fps on 8 gb ram when i had it (on 16 now) windows defender is fine that one doesnt go haywire on the game. hmm. hope someone else chimes in but a fresh install wont hurt.
tried tweaking graphics? (both higher and lower? i have heared before that when putting it higher it suddenly worked better for some)

go into game options and pick the ones with best performance, less fancy. See if it makes a difference. If it does, than it was about graphics, if not it is something else. I do not think it is about graphics as your pc is pretty good

1 Like

I did that multiple times. Literally makes no difference. It also doesn’t make any difference if i put 10hearthlings or 30hearthlings, or having inventory cap at 5000 or unlimited. It’s just lagging without a reason. Task manager is telling me (while only running the game, no background programs, even discord turned off) that cpu, gpu and memory are still not at 100%. I have absolutely no idea what’s causing it. The only thing left is to do a clean re-install, see if it’ll work, and if it does install mods 1 by 1 to see if a mod is causing trouble…

Edit: OK so i turned all mods off again, just to be sure and it works at like 50-60fps now. I guess it really is all the mods that i’m using, just which one? I’ll find that out myself. Thanks for responses guys lol.


there is a list in the ACE discord of mods that we know work and dont blow up the world. especially old or outdated mods have risks of glitchyness