Am stuck in Winter

I am playing a heavily modded stonehearth game (without ACE) and the Biome mod, wich I use has a bug, that makes winter last for 300 days (its a compatability issue, already talked with the author) So i just wanted to know, if there is a better way to skip winter, than using the time slider.

EDIT: btw heres a screenshot, after a few days

The game has only 84 days in a year, so something is really messed if it has 300 days

1 Like

Yeah, no clue how that happened. Basicly the mod author said, that he doesent have that problem, and thats it. I dont have any other problems, just 300 days to skip.

This Biome is made for Stonehearth and ACE, and shouldn’t conflict with other mods. You will likely run into problems if you are not using ACE, and are using mods that conflict with ACE.

Those were my exact words. Insisting on not using ACE and using my biome is likely causing problems.

1 Like

Why it needs ace?

I use direct stonehearth_ace strings to generate my own mining table. For that matter, a lot of the plants and trees in this biome as well.

You don’t need. You can simple add

   "mixins" : "stonehearth:mining:base_loot_table",

To the start of the file. This will import everything from that file into your, ace adds stuff to that file, so it will automatically added to yours too

I’m aware, I just wanted my own balances, I didn’t enjoy certain overflow of resources.

Only the lines you add replace the values in the original file, the ones missing will be the default from original. So you can just ignore the uris and change just the weights.

Would that prevent any issues?

Your loot_table would have a few empty uris in case ace is not active, which will just default to no item being dropped, and when ace is active, it will drop that

1 Like

@KillerGurke_16 it’s my mod that is doing that! “Necromancer Mod - Box O’ Vox 2.0”
That is, if you are using it. I recently did some things to increase the length of a game year to more closely match real life. I converted the default Biomes to work with this change, but if you are using a modded Biome I’d need to know in order to convert that file when my mod is active. Alternatively you could simply disable my mod while playing.

Default game months last only 7 days, I made a month 30 days. With 12 months at 30 days, the year is now 360 instead of 84. Temperate Biome uses the most realistic values by having each season be 3 months long.

Apart from making the game year over 4 times as long, I personally haven’t come across any errors that haven’t already been fixed.

I’m sorry for the inconvenience :slight_smile:

I am using your mod, (I would not want to disable it, because the undead workers come in handy) The biome mod I am using is the omnirerrain biome.

BTW would I need to start a new game, or will your fix work on any existing save?

1 Like

Unintentional promotional Game of Thrones “Winter is Here” mod :jubilant:


updating it right now! I’m pretty sure my fix will allow you to stay on an existing saved game.

well if you play in the Arctic Biome, winter last 7 months.

It’s updated now! Hope you enjoy!

1 Like

Comes a bit late, but THANK YOU it worked. also @Omni sry for sounding like a a-hole, I was just kinda desperate about 300 days of winter

1 Like