Alpha 8 Release 205 - Me new Callsign: Bugattractor2007?


so after some hour gameplay i have found some bugs … at first the game crashes very often at the moment…

1- When somebody dies in a party - the dont vanish or can be remove -> party doesnt work anymore -> resolution delete and make new:

2- there are no scrollbar for the workshops and when you change the order direction via drag and drop you get this error (also the crafting system doesnt work correctly -for example you want a comfy bed and for this you need a mean bed - if try to make a comfy bed before the mean bed - it blocks the complete list (also i doenst help to set the order behind the mean bed -> you must delete the order for resolution)

3- workers (in this pic the carpenter) stuck idle

he is sleep and he is hungry but he cant walk anymore … if i remove the job - he try to walk but the he fall asap asleep and cant walk ^^ resolution save and restart

4- the burining goblin (i think this is known in older versions ^^)

5- an old bug - before the remove the scaffolding the should remove old items from the building :wink: resolution = build own ladder

6- they can fly! OKKKK they can levitate ^^ they want to sit in the chair but now the levitate over them -

7- mining brings the system to stuck ^^ 6 worker and a big mine xD

8- goblins cant be killed and they dont do anything anmore xD

last but not least the biggest issue (but ka why this happens)

there are problems with the UI - at some point it doesnt will open any window - if you try to save it doenst do this and overwriting delete your saves but no new save … (i have lost 6 days and 6 new villagers xD)

here is a screen of slicemode on but no info

and sometimes the game close automatically without info - one time i have seen a quick info because authorization but it was gone to fast to make a screenshot or read it ^^

now some suggestions:

  • first i think the ore rate should be increased!- i have search the hole map and only found gold - then i have make a big mine in the mountain and again nothing
  • in the template menü an quickbutton for normal walls and perhaps an option to make them thicker then one block
  • for the flooring menü gras? so you can hide false mining OR an option the fill mined holes ^^
  • in the options is an false link to the bugs :wink: its not category its only “c” - perhaps this as a link so its open the forum automatically
  • integrate the mouse wheel in the crafting menüs - so you can easy scroll the list and perhaps the orders

i hope this helps you. have a nice day and like ever: NICE WORK!

edit: i have get the error message again: Assertion Failed i ! = end(c:\rb\root\sh-ob0-build\stonehearth\source\horde3d\source\horde3denginge\egrendererbase.h:65)

For number 3 (lazy/idle Hearthlings) does this occur as soon as you load the game, even if it wasn’t before? If it is just restart the game before each time you load and they shouldn’t do that. I have had this glitch and its the only work around I know of. Probably some line of code that has not ended properly to do with the heathlings whenever you try to load from a world(My educated guess).

i get this while im playing - i have missed my carpenter and searched him ^^ after saving and reloading he works fine

You get lots of ore just by digging in rocks! In this pic, the whole mine is in the dirt and the rock starts where the gold vein is.

If you are just looking for veins that you can see without digging, then they are usually on the side of rock cliffs.

When im mining i have no issue getting ore. In fact i find just as much ore as rock!

If they added more veins in the game it would be way to easy!

hmmm i have only found the gold veine (and if have used 2 soldiers because of the fog of war to search all cliffs) ^^ perhaps i must dig deeper? next version - next try :wink:

I find sometimes they are hard to see and it could be a visual bug (not sure) But i did mine out a large area in a mountain to build houses inside and found more veins the lower i got!

Not sure if that was just luck or the way its supposed to be!

Personally i dont go for the veins unless i cross an iron one. Just dig in rocks and you will find lots of all kinds of ore!

tried and confirmed ^^ when i digg deeper i have found grey stones (rock) and there i get also ore ^^ my failure was that i have only digged in “dirt” and only search for veins D

soo 2 more bugs ^^

1- after reload i have some new farms ^^

  1. visual error - after remove and replace of the flooring form the dining hall - it doenst show the new chairs and tabels anymore (resolution reload) and he still shows some building errors (redline aorund the buiilding)

next one ^^

suspended mines will be digged after reloading - so i think this setting wont be saved corrctly

Resolultion: remove suspend and set again ^^

I have seen the floating hearthlings over chairs while eating as well, and I have mentioned idle hearthlings starving in another recent post.

1 Like

sooo and another bug - at the moment i can´t reproduce him.

i tried the templates function to check if i can make pngfiles and templates to share with others.

after some restarts the windows from my template are moved one block to the left while building? i have tried it with another building of this template and some restarts - not happen again?

the last pic shows how it looks after fixing while building ^^ after the building - there is no option to fix it ^^

and while the test of 10 reloads its also shows everytime the old notification that 2 footmen was upgraded (10min before saving) ^^

hmmm i think the templates dont like me ^^ two tiny cottages - change the walls to stone - at the left he has accept it and on the right only for the front ^^

and same two issue again - workers stuck on idle (but there is enough work to do and worker doenst find way and try to sleep on the floor so the same notificaiton shows every second.

this doesn;t have anyting to do with an solution.
but your vilage looks awesome!
can you make a big picture of it?
i love it :smiley:

1 Like

here two pictures ^^

and next critical bug - if i try to remove one of the tiny cottages - the game crashed complete ^^