Alpha 13 rather unplayable, sorry

I put a similar thread up on steam hoping to get an eta of a heavily need patch…

I tried three games, and every one was broken less than an hour into the game. Every other error/bug mentioned in the various threads over at steam happend to me (unplaceable objects giving lua-errors, hearthlings not building, lag, etc)…

This is so sad, as the game was looking really promising.

And on a final note: “Alpha” shouldnt be confused with “releasing a sloppy, unfinished build”.

its alpha… i know you dont want to hear it but the game isnt released yet… we are simply being allowed to play it while they are still working on it. and with thanksgiving im sure they wanted to release it before thanksgiving and get feedback while they take a break for awhile… they are human and need breaks as well.


It is rather unfortunate that the Alpha 13 Build ended up buggier (Or just more game breaking then before) then all the Development builds. It is also unfortunate that it fell with in line Thanksgiving so the team have not been at the office, however i’m sure TR will be as quick as they can to address the issues.

As someone who kickstarted the game it still does look very promising. The progress the team makes, all the updates and development streams along with plenty of community feedback gives me much higher hopes then many other ‘Alpha’ games that seem to make little to no progress whatsoever.

Lastly Bugs happen. The game is in Alpha so it’s kind of to be expected. Not every update is going to be perfect and this is true for all games.


Weird, my game is running smoother than ever. I have more hearthlings than I’ve ever had, More buildings than I’ve ever had, less bugs, and it’s running at a higher FPS with the graphics turned up…

This is on a four year old machine running on the 32 bit version.

Whatever your issues, I’m sure they will get ironed out in time.


I don’t believe that the developers frequent Steam that much. Most of the discussion occurs here on the Discourse.

To address the first two bugs you listed, the unplaceable object bug was fixed during the Thanksgiving Holiday and is awaiting the next release. The Hearthlings not completing roofs has been acknowledged by the developers (as soon as they returned yesterday) and they are working on a fix.

As @AdriannaVentara and @Tranzy stated, it unfortunately was bad timing as the release went out right before a Holiday here in the US and thus the developers were not around. With the last Alpha release, there were 2 minor updates to the stable build just after it came out. I would expect the same here!


seeing on how we are on this topic, I have found this game somewhat unplayable. That dosent mean I cant build houses or dwarven settlements, It just gliches the people in my settle out and makes it harder for me to construct things. here are four errors I ran into when trying to make a video for tips on how to build.

that dose not mean it cant be fixed for a latter time. The devs have tried their best to create awesome content.
develop-2733 (x64)
std::logic_error: 'invalid reference in native get_id’
stack traceback:
radiant/modules/events.luac:84: in function <radiant/modules/events.luac:81>
[C]: in function 'get_id’
radiant/modules/entities.luac:105: in function 'get_world_grid_location’
stonehearth/lib/build_util.luac:366: in function 'grow_local_box_to_roof’
stonehearth/components/column/column_component.luac:38: in function '_compute_column_shape’
stonehearth/components/column/column_component.luac:13: in function ‘layout’
…nehearth/components/building/building_component.luac:138: in function ‘layout_roof’
…nehearth/components/building/building_component.luac:92: in function ‘_remove_structure’
…nehearth/components/building/building_component.luac:124: in function 'obj’
radiant/modules/events.luac:44: in function 'instance’
radiant/modules/events.luac:98: in function <radiant/modules/events.luac:96>

radiant/modules/entities.luac:38: in function ‘destroy_entity’
…uction_progress/construction_progress_component.luac:28: in function ‘set_finished’
…arth/components/fabricator/fabricator_component.luac:338: in function ‘_update_fabricator_region’
…arth/components/fabricator/fabricator_component.luac:60: in function ‘set_teardown’
…uction_progress/construction_progress_component.luac:43: in function 'set_teardown’
stonehearth/services/server/build/build_service.luac:46: in function 'cb’
stonehearth/services/server/build/build_service.luac:34: in function '_call_all_children’
stonehearth/services/server/build/build_service.luac:31: in function '_call_all_children’
stonehearth/services/server/build/build_service.luac:45: in function 'set_teardown’
stonehearth/call_handlers/build_call_handler.luac:7: in function <stonehearth/call_handlers/build_call_handler.luac:6>

develop-2733 (x64)
radiant/modules/entities.luac:37: attempt to call method ‘is_valid’ (a nil value)
stack traceback:
[C]: in function 'is_valid’
radiant/modules/entities.luac:37: in function 'destroy_entity’
stonehearth/call_handlers/entities_call_handler.luac:5: in function <stonehearth/call_handlers/entities_call_handler.luac:5>

develop-2733 (x64)
c++ exception: lua runtime error
stack traceback:

develop-2733 (x64)
stack traceback:
stonehearth/services/server/threads/thread.luac:87: in function <stonehearth/services/server/threads/thread.luac:87>
[C]: in function 'fn’
stonehearth/services/server/threads/thread.luac:98: in function <stonehearth/services/server/threads/thread.luac:96>
[C]: in function 'fn’
stonehearth/services/server/threads/thread.luac:109: in function 'private_msg’
stonehearth/services/server/threads/thread.luac:168: in function '_dispatch_messages’
stonehearth/services/server/threads/thread.luac:128: in function 'suspend’
stonehearth/services/server/threads/thread.luac:146: in function 'sleep_realtime’
stonehearth/components/ai/ai_component.luac:187: in function '_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function 'xpcall’
stonehearth/services/server/threads/thread.luac:89: in function 'f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>