Alpha 13 Feedback

Alpha 13 is looking great. The desert biome is a lot of fun. There are also noticable improvements to task AI.

I ran into a few issues that I wanted to share.

  1. I somehow hit exactly 500 wealth, and even though I fulfilled my other achievements for happiness and food, I didnt get a new resident. It looks like this is because I didn’t actually exceed 500 wealth, although I met the requirement.
  2. I formed a party and had them attack a goblin camp, but only half of them ran in and then cowered. The goblins also cowered, so it was a stalemate that couldn’t be resolved. One party should win.
  3. The new job manager is great. It allowed me to work around job allocation issues. The biggest issue that I saw was that when hauling, or moving, or doing jobs, the hearthlings would just get stuck in position with glitchy animations (bouncing between frames). If I cancelled the current job it would temporarily fix the issue and let them do something else, but they would eventually get stuck on that new task also.
  4. This is a long-standing issue, but please let me delete buildings from the building list. I have added some in the past (Alpha 6 or 7) that are no longer supported. Now the building snapshot is not displayed any longer, and clicking on it throws an exception.

One request is to make it much easier to cancel tasks that are not yet started. For example, if I place a ladder but no hearthling has laid a block yet, I want to cancel the ladder. I cant find a way to do this.

Also, the desert biome requires a lot of digging. At ground-level this is simple, but with the boulders sticking out of mountains this becomes more difficult. Please consider having the hearthlings carry spare wood to build temporary ladders to reach their task areas. I dont want to have to lay a single ladder every time, and even if I do, sometimes I put it in the wrong place (i.e. the single block they want to reach is still unreachable because the ladder is slightly misplaced). Just let them do it themselves.

P.S. I have a current save file that shows #2 and #3 above. If its possible to share saves, I can send it in.


Hey there @Kilfaxi, you absolutely can upload saves! To upload a save locate the folder (default is C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games and copy the folder to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and copy the sharing link here. Going to ping @Albert to review the logic behind issue #1, and @sdee for issue #2.

I do really like you suggestion for ladders to be automatically constructed while mining like building. I have had similar issues when in the desert, and that would be a great way to fix it.


Hi @jomaxro, thanks for the feedback. Here is a file dropper link for you guys.

A couple notes:

  1. You can see the difficulty with mining if you go try to mine the boulders near the house on the cliff face.
  2. The goblin camp is up on the mountain behind the town. A party is already created in that save file, and there is a ladder. You can issue an attack command to reproduce the cowering issue.
  3. The job bug where the hearthlings get stuck and repeat animations may not happen at first, but if you play that save for a bit it should happen. The trapper was doing it a lot, but I doubt their current tasks and such were stored in the save file. They will probably start doing new things when the save is first loaded.



There is a cancel task function already, its under tools, its the circle/arrow box. Just select it, then draw a box encompassing the tasks you wish to cancel on the game world.

Thanks @Communistpenguin, has Cancel Task worked for you on ladders and such? In Alpha 12 I didn’t always have luck with it, and I tried it on my save game to no avail.

It does seem to work consistently on things like cancelling tree and resource harvesting.

If I remember, the cancel task works for :

  • Harvesting
  • Placing to
  • Moving from … to …
  • Removing to stock
  • Looting
    The ladders can be cancelled by clicking on the red cross before and after being built.

i just checked and the cancel tool does not work on ladders, however, you can simply select the unbuilt ladder, and it has a red cancel x as an option


That’s what I said. Also you may notice that you cannot remove ladders built by your workers when a house is under construction.

I just bought the game and started a game with Rayya’s Children in the desert because that sounded like the most fun.

  • The racoon just doesn’t seem to belong. A quick fix would be to reskin it as either a Coyote or a Scorpion for desert fun.

  • When I have selected a harvest tool left clicking adds squares to a gathering or mining order. It would be nice if I could simply remove blocks from the order by right clicking. As it stands now I have to select the build area without accidentally choosing another square, and then cancel the entire zone. That’s really clunky.

  • Enemies come at night and I easily vanquish them . . . but then some of my hearthlings lie down to sleep on the ground even though they have beds. It would be nice if I could select them and poke them awake. Even if I have to bop them repeatedly and have them gripe at me every time that would be more fun than watching them sleep on the hard ground away from the protection of camp.

  • Sitting . . . I put four stone benches around my campfire and people sit in them to eat but . . . they sit NEXT to the benches, on the ground at night. This drives me crazy. I know there may not be enough benches for everyone but sitting on the ground NEXT to a comfy chair? It’s another point where I want to reach in and slap my hearthlings. lol

  • Digging wells . . . I settled in the desert away from water and am having no problem. Something just seems off about this.

  • Overall great job. Thumbs up! Hope you are enjoying your holidays and having lots of fun. I know alpha 14 is supposed to be the big critter update. :slight_smile:

1 Like

Hey there @John_Chance , welcome to the Discourse, and thanks for the feedback! :smile:

Still playing and I’ve encountered something that really needs looking at . . . I went to build a simple open pavilion to cook in. It should be a nice elegant building with a couple posts, maybe a back wall, a floor, and a clay roof. But the walls auto complete a full enclosure and when i build the structure out of slabs it won’t let me put on the roof because it isn’t a “walled structure”. Even worse when I take the time to build the entire thing out of slabs I never get a “finish editing” or “build” button. That only appears if I put a full circle of walls on the roof!

So I’m going to try some other methods to try and get myself an open cooking pavilion that should look awesome in the desert but in the meantime I’ll share my frustration and hope something can be done about this! :slight_smile: