After Correcting an Unfinished House, Pathfinding "Explodes" (Problems with Construction = Lua & Pathfinding Errors)

I had Pictures of the event as it happened, but because of “New Member Restrictions”, I could not put them in this report.

First, I came across the notorious unfinished house bug due to some stairs I put on the outside of my house, but enough was enough, so I began trying to find a solution to complete the house. To finish the house, I tried placing ladders within and around the building that was not being complete, and surprisingly, it began working. The Hearthlings would use the ladders to ensure the building’s completion. I was excited to see I found a player fix to a devastating bug.

But after they finished, as they were taking out the scaffolding around the house, a small repeating error about some AI occurred, but stopped after about 7 repeats (I had 7 Hearthlings at the time), so I was not worried about this occurrence. I noticed a smaller bug about some animations not running, such as the Hearthlings suddenly could phase through doors, so I saved and reloaded the file.

After reloading the file, the Hearthlings cleaned up the rest of the wood around the house and once they finished the same engine error occurred and repeated, but this time it never stopped repeating until the game was drastically unplayable. The error repeated until there were over 6000 pages of errors. Each repeat added about 200 pages to the error console. As it repeated the path finding in the game’s task percentage increased to the point it was 66% of what was “happening”.

The error console mentions many things about running and calling what seems to be AI actions (I could not copy the error do to the intense lag that occurred from the error) so the bug overall seems like it is related to the relation between construction and AI. Having seen the recent Dev streams, I know that you are aware of these sort of bugs but I had a feeling this case puts them together quite easily.

If you would like to try to replicate it construct a building with an out side stair case and once it is to the point the Hearthlings don’t complete it, add ladder around the incomplete walls until the finish the building and it should likely follow the same course of action.

Thank you Team Radiant for the hard work and amazing game, I hope development runs smoother and smoother as you rid more and more core bugs. Sorry if this report is a bit wordy I could not insert any pictures and was unable to give the exact error log.
(I am using the Latest Unstable Build)

The massive repeating error occurs when the Hearthlings cannot finish a pole like structure and an additional ladder is added for support. The first page error log is below as a reply.

Second Part(Seemingly related but only by tangent):

While playing a new file (which I did create the same building in just in a a different way and it worked fine), I went to place some fine wooden chairs. Though I noticed that the chairs started to accidentally make copies (!?) and these two new copies were picked up by two different Hearthlings. When they did, they froze and the lua count on the task meter begun to climb to ~50%. At this point I only had added one Hearthling total to my town (one had died earlier).

Everyone else in the town could keep doing what they were doing and no error log appeared. Just these two Hearthlings seemed to be stuck in limbo of thought on what to do with these “fake” chairs. The reason the chairs were picked up seemed to be related to the fact I asked to place them, but all of the placements were already complete. I could not place any new chairs because they were not actually part of my town, they were “fakes”.

Just a word of thought, both of these bugs/errors may be occurred by AI loops that aren’t perfect.

(Also the building was done but they didn’t take down one wall of scaffolding that was blocked by stairs which caused the same error as mentioned before until I placed a ladder next to it which ended the error loop but did not get rid of the scaffolding)

1 Like

If you still have the screenshots and save game, zip them and upload them to a filehoster (easily found via search pages).

I may be wrong but I think that the devs might want to see this.

1 Like

I was able to repeat the error and it turns out it was when a specific stack of blocks that made up a pole wasn’t working but the scaffolding was in place, place a ladder on the other side and the first page result is

develop-2494 (x64)
stonehearth/components/ai/execution_unit_v2.luac:316: bad argument #2 to ‘format’ (string expected, got userdata)
stack traceback: stonehearth/components/ai/execution_frame.luac:656: in function <stonehearth/components/ai/execution_frame.luac:649> [C]: in function ‘format’ stonehearth/components/ai/execution_unit_v2.luac:316: in function ‘?’ stonehearth/components/ai/execution_unit_v2.luac:12: in function ‘abort’ …tonehearth/ai/actions/run_putdown_effect_action.luac:9: in function ‘call_fn’ stonehearth/components/ai/execution_unit_v2.luac:16: in function ‘_call_run’ stonehearth/components/ai/execution_unit_v2.luac:185: in function ‘_run_from_started’ stonehearth/components/ai/execution_unit_v2.luac:128: in function ‘_run’ stonehearth/components/ai/execution_frame.luac:439: in function <stonehearth/components/ai/execution_frame.luac:439> [C]: in function ‘xpcall’ stonehearth/components/ai/execution_frame.luac:658: in function ‘_protected_call’ … stonehearth/components/ai/execution_frame.luac:101: in function ‘_run’ stonehearth/components/ai/execution_frame.luac:338: in function <stonehearth/components/ai/execution_frame.luac:329> [C]: in function ‘xpcall’ stonehearth/components/ai/execution_frame.luac:658: in function ‘_protected_call’ stonehearth/components/ai/execution_frame.luac:340: in function ‘run’ stonehearth/components/ai/ai_component.luac:128: in function ‘_thread_main’ stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89> [C]: in function ‘xpcall’ stonehearth/services/server/threads/thread.luac:89: in function ‘f’ radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>

The corrections to the house don’t seem to have any effect because I could play on and on without trying to correct this one pole.