Advice / issue solving needed

also remove the master :wink: out and in the zip ^^

i have compare your files with the wallcrest and can see any bigger differences … so i think you need from our mastermodder like @Drotten or @Froggy :smiley: sry to all not mentioned :wink:

Great thanks, will do that in the future.

Hopefully those masters can help out :stuck_out_tongue:

1 Like

I had this issue too when doing wall furniture, and asked Froggy about it in the past since he has the mill for the Stonehearth Cafe mod.

It seems to be something related with the distance of the ladder to the wall. The hearthlings can’t reach the wall to place the shelf because it’s somewhat far. It’s really tricky to get it working. I finally finished a working shelf, but for placing items on it you had to manually place a ladder.

My suggestion would be to fiddle with the collision regions and the adjacency.

2 Likes

Thank you for your idea. By regions is this the ‘region_collision_shape’ on the main json file? And what do you mean by adjacency?

Thanks, again :smile:

1 Like

Yes, that one.

The adjacency is which sides of the item can a hearthling approach to. I messed with it so bad one time, that they were placing the shelf from the other side of the wall :cold_sweat:

If you use the entity editor of the debug tools there should be a section for modifying it.
In the potter_kiln json file, the mob component has this:

“destination”: {
“region”: [
{
“min” : { “x” : 0, “y” : 0, “z” : -2 },
“max” : { “x” : 1, “y” : 1, “z” : -1 }
}
],
“adjacent”: [
{
“min” : { “x” : 0, “y” : 0, “z” : -3 },
“max” : { “x” : 1, “y” : 1, “z” : -2 }
}
]
},

it determines the destination region and the adjacency. I guess you should avoid to have adjacency with the part that touches the wall, you might encounter the situation I mentioned above :disappointed_relieved:

Also there’s a property ( “allow_vertical_adjacent”: true ) mentioned in ghost files of entities like curtains or banners. I think it’s used to allow placing items on top of items, but I’m not sure how it works.

Edit: first just try to modify the collision shape. If the ladder problem persist, then yes, try things with the other regions.

1 Like

Right, time for some trial an error I suppose. I have seem the allow_vertical_adjacent and think I actually used it on this bookshelf.

Thanks for the info will see if I can figure it out.

Do you have any idea on what would be causing the other issue I am getting, where the item cannot be placed on some walls? @Wiese2007 said he also tested and had the same issue.

1 Like

Sorry for the questions, but looking at these models within Stonehearth, is the size of 1 Stonehearth unit 10 voxels?

1 Like

I’ve just seen your code and it looks right :confused:
I will try to test it too.

I’m not sure what can be causing it… The collision region looks actually small, let me check it in game.

Btw, if you have “enable_debug_keys” : true, in your user_settings.json, toggle with F11 when in game to see the regions (gray box is collision, red box is destination region).

I think that’s the default scale, yes (0.1).

2 Likes

YES! You legend, was trying to figure out why I couldn’t see these boxes. Gave up in the end thinking it had been removed. Right let me see why this isn’t working!

1 Like

Yep, you might have to adjust your model origin and the collision box first, then try to figure the other issue.

1 Like

I just noticed that as well. This might be a little ‘nooby’ :stuck_out_tongue: but what axis are each of the colours? I never really done 3D work.

I’m assuming in the debug tools entity editor the boxes are in the order x, y, z as well?

1 Like

Yeah, should be.
If I’m not mistaken, (some 3D editors have the axis placed different but usually the color is a standard), the red one is X, the green one is Y and the blue one is Z.

Ah, here’s the reference:
http://discourse.stonehearth.net/t/reference-positioning-placeable-items/14858?u=relyss

1 Like

That was a very helpful read haha. I have fixed the boxes/positioning etc. Will try and see if that helps with wall placement. I have attached a screenshot showing the new boxes. Any idea what the purple one represents?

1 Like

YAY! They now place the bookshelf on the wall, so must have been the boxes not set properly. Now just need figure out what is preventing it from being placed on certain walls? Seems to be if the wall is a certain angle?

Edit: Actually that fixed both of the issues. They were both caused by improper positioning of collision/placement boxes. Glad that is sorted, was really making me pull my hair out haha. Thanks for all your help @Relyss and @Wiese2007. I have pushed the new changes to github and here is a smod file, would appreciate it if yourself or anyone else could give it try make sure I found the problem :smiley:.

3 Likes

It might be. I remember some time ago Froggy complaining that you couldn’t place items if the wall was facing certain directions, but I don’t remember what was the reason for it. On a second thought, I think it was a different issue, directly related to the regions. Here it just shows you the red cross without any possibility :pensive:

Edit: oh, you fixed it :smiley:
Great!

2 Likes

I think you’ve wrapped the smod wrong, it doesn’t load correctly, I can’t see the recipe in the list.

I think currently you have to zip the mod’s folder, not the contents.

1 Like

Oh, oops! Thought that was how you did it. I have updated the dropbox link with a rezipped file.

2 Likes

In the past, yes. But now if you unzip the stonehearth.smod you’ll see that inside it’s the folder, not the contents =(

Well, now it works perfectly :smile:

Just a minor issue, the shelf is not touching the wall, and the purple box seems to be the cause of it :confused:

But I’ve never seen that box before, so I don’t know where is it coming from. I also had lots of problems to place an item touching the wall on the exact point… Sometimes it’s tricky.

1 Like

Will look into the purple box, or just move the shelf back slightly, if that would work :stuck_out_tongue:

The positioning issue, it seems to be, what I noticed anyway, is that the mouse isn’t over the shelf, instead it is off to the left for me. Maybe that is what is causing it to be difficult to position.

2 Likes

If it’s off, that probably has to do with the model / region origins.

1 Like