Adding doodads causing bugged construction

Hey all;

I know this has been touched on before and if this needs to be moved @SteveAdamo or @Relyss, please do.

In this post (Workers Never Finish Stone Roofed Houses) @Helldiver stated that ‘bugged construction’ caused ‘bugged games’ resulting in severe pathfinding errors and just overall problems.

I built a new village (The content village of Spankington), and built up a few different (Radiant standard, templated) structures (read: shared sleeping quarters, dining hall and the like), being careful to only build the doodads (chairs, doors, etc.) AFTER the scaffolding came down. This resulted in nice, finished buildings with smart grey borders around them. But…Nice buildings need decoration, especially buildings in a town as lovely as Spankington!

Well, as soon as I added a flowerbox (a brightbell box, to be exact), to one of my finished dwellings, the border around the recently updated building turned red and my workers wouldn’t finish the building they were currently working on.

I just thought I’d report this, and see if anybody has had this happen as well. I mean, we can’t have our hamlets failing to thrive because of flowerboxes! Think of all the wonderful little communities like Spankington, Silverside, Trillmoor and West Knickerdrop that will be shuttered and never be able to reach their full potential…

All because of a flowerbox… Terrible.

1 Like

can you try to replicate this, and provide the associated repro steps, along with some before/after images? thanks!


Step 1) - Build any building (one of the template buildings, i.e. Dining hall, shared sleeping quarters, tiny cottage, etc.), and wait until the building is complete to add the doors, beds, tables or what have you.

step 2) - When the building is finished, add your doodads.

step 3) - When the building is completely finished, you should have a gray border around it -

This is a shared barracks, made from a template. notice the gray border - completely legal build.

Step 4) I simply added a flowerbox, and this is what happened:

Same barracks, but now the build has become ‘illegal’… Thanks to the addition of the flowerbox.

I don’t think this happens with banners, but it might be worth looking into :smile:


I’ve experienced this and I’ve seen it in other report. The game notices that you’re trying to place an object on a not-allowed area (the building). Question: how did you put the flower box: manually or through the edit building UI? (I haven’t played much with the template system, I get confused when I don’t see the build button and sometimes I click the undo button thinking I can go to the previous window :sweat_smile: at least I think I’m not the only one)…

I added it after the fact, through the manual placement method :smile:

Then I think that’s what caused it. >.>

I have no doubt :slight_smile:

Just doing my part to let radiant know about potentially problematic problems!


Thanks for the report! Editing built-buildings is still a touchy proposition. Does the same thing happen if you try to put up flags or wall hangings?

I just experienced this issue caused by adding a tapestry then on another building by adding a flower box. Both were done by manually adding to the buildings.


It doesn’t happen with flags. I just tried that out this morning and there were no red frames. I will try it with wall-hangings (both inside & outside buildings) and keep everyone posted! :slight_smile: :+1:


Good to know. Thanks!

Hey all!

2nd Update: I added some tapestries to the mix. When the tapestries are added to the INSIDE of the structure, everything is fine, but when you add them to the OUTSIDE… Now, that gets you this (it happens with woodens signs as well)-
Illegal building? Not on my watch!!!

So I tried to remove the tapestry, and rotate it into the inside of the house… Then I got this nifty LUA error.

My Hearthians wouldn’t move the offending wall-hanging, so I attempted to undeploy it.

Negative, Ghost Rider…
It would not undeploy either.

This all happened AFTER the placing of the tapestry outside. So there you have it, it seems that these errors might have soimething to do with placing stuff on the outside of the building. What do y’all think?

I would like to thank the fine citizens of West Knickerdrop, for their cooperation and help in bringing you this last bugged building update.

No Hearthians were harmed during the making of this post.


In my case adding the tapestry to the INSIDE of the building caused it to bug out. I have not tried flags yet. I will try again and capture screenshots sometime tomorrow when I get a chance to play again.


Before adding tapestry inside my dining hall.

After adding tapestry inside my dining hall.