ACE - Authorized Community Expansion Project


#283

Are the mushrooms part of ACE/Highland biome? If so there’s an issue with the Herbalist recipes under fungal refinement - they call for one mushroom but when gathered or bought they make baskets of mushroom so these recipes can’t be crafted


#284

You have to undeploy them, not harvest :slight_smile:

Think of a silkweed, to plant it somewhere else or use the plant, you need to undeploy it. To consume the fibers, you need to harvest it :slight_smile:


#285

Ah ok thanks :slight_smile: makes sense


#286

I’m sorry if I’m being a pain! This just popped up after my last reload - tbh yes this is a saved gave from before the latest update so it may be because of that

release-947 (x64)[M]

stonehearth_ace/components/vine/vine_component.lua:196: attempt to call method ‘bind’ (a nil value)

stack traceback: [C]: in function ‘bind’ stonehearth_ace/components/vine/vine_component.lua:196: in function ‘_start’ stonehearth_ace/components/vine/vine_component.lua:135: in function <stonehearth_ace/components/vine/vine_component.lua:126>


#287

Yes, it’s caused for being an older save. The error is harmless :slight_smile: No worries!

PS:

Please don’t think that! We love getting reports and feedback, we want to improve things and make it good for everyone :slight_smile:


#288

It’s actually a different vine error that can happen that’s a problem with backwards compatibility (and can be ignored). :stuck_out_tongue: This one however is a weird current issue, and I think I know the solution and we’ll probably have another hotfix out soon. Worst case scenario with it is that the particular vine entity that this error popped up for won’t grow.


#289

With the Fortify mod being out of date, would it be possible for ACE to add similar components since y’all added trapdoors? Someone was askin’ about a Drawbridge in another thread.

Also, some sort of rally device that acts as a passive town defense mode specifically for shepherd animals on days with inclement weather. Maybe a patch of straw bedding, or an input container for animal feed pulling double duty. Have it check the weather at the start of the day and if it’s bad weather then it calls the animals into whatever shelter we’ve placed the item in. Not sure if this is possible or if you’d need a separate item for each animal type.


#290

The animal thing is already planned. Drawbridges have been considered but haven’t been a priority.

Edit: You’re welcome to look at the Trello boards linked in the top post. They’re not exhaustive of the ideas we’ve considered/approved/etc., as despite our attempts to stay organized, a lot of the project is done on a rather ad-hoc basis, but they provide a pretty good idea about a lot of the features.


#291

The animal thing sounds amazing. I hate that atm I have to build shelter over the whole pasture to keep them in good condition. Being able to just have a barn they go into would be amazing. :heart:


#292

Hey just wanted to let you know that you guys need to fix the animation for rabbits using crossbows, I forgot to save a screenshot but it isn’t hard to reproduce, basically a error pops up saying something about an error in the rig and the rabbit kinda spasms every time it tries to fire the crossbow and as far as I can tell it doesn’t actually do any damage.


#293

For some reason the Northen alliance and the raya child get almost no metal when digging, even at bedrock level, making impossible the already hard difficulty.
With the new recipe the raya children dont have enougth wood too.


#294

You need to find veins, randomly digging seems to not be enough to get metals on any kingdom (could those values be upped a bit?)


#295

Hi there! I returned to Stonehearth today and decided to try this mod but I have come across a problem, my carpenter won’t craft the most basic bench. I disabled this mod and he crafted it right away. What could cause this?


#296

You have probably heard of this bug and it is on the steam discussions but I have had multiple games were a unit (so far only military, one archer and one footman) who is glitched, this happens later in the game, probably around the 30 hearthling mark. I got a notification that it could not find food and when I click on the notification or select the unit from the hearthling list my screen goes dark, it lookes like then I am looking at the world in slice mode. I have reloaded the save and tried to find the hearthling glitched in the world with the slice tool but was unsuccessful. When my screen is dark it kind of looks like I can see a VERY faint outline of somethings but is otherwise completely gray. The UI is still visible and music continues to play. I also have to x out of the whole game because it gets stuck in the loading screen and the first time this happened I didn’t have auto save on and I ended up just quiting that save. It does seem possible to let the hearthling starve but it is super frustrating. I tried to give as much detail as I could. I definitely recommend auto save. Otherwise great mod, must have.


#297

@Hexwall
A couple of people reported this issue but so far we were unable to reproduce - turns out the issue was with other mods’ incompatibility with ACE (and not ACE itself) - so if you’re using mods like SmartCrafter, try disabling them and see if it works :slight_smile:

This is apparently a base game issue (not ACE)
Some of us were discussing it earlier and apparently it happens without ACE - seems to be related with having large military parties (like 4~5+ people?) and when they are patrolling and doing their dancing around to “stick in formation”, sometimes one of them might “glitch” out of the world if the patrolling route passes near terrain edges like upward cliffs (the game tries to relocate them in formation, puts them “inside” the cliff and they fall)

Spreading your units across multiple squads might help - but we’ll see if we can do something about it in our end


#298

@DaniAngione well I dont have any mods installed I think? Its just the vanilla game. Regardless I will now list all the smods that are in the folder:
autotest_framework
candledark
debugtools
frosfeast
microworld
northern_alliance
radiant
rayyas_chidlren
stonehearth
stonehearth_autotest
stonehearth_tests

I only have the required ones plus debugtools and stonehearth_ace.


#299

I only have activated*


#300

candledark and frostfeast are most definitely mods and or outdated.


#301

I know that but as I said up there i only have the required mods plus debugtools and ACE activated


#302

@DaniAngione I forgot that this error pops up and im sure its related

release-947 (x64)[M]
…key_patches/ace_collect_ingredients_orchestrator.lua:17: attempt to call method ‘get_component’ (a nil value)
stack traceback:
[C]: in function ‘get_component’
…key_patches/ace_collect_ingredients_orchestrator.lua:17: in function ‘run’
stonehearth/services/server/town/town.lua:473: in function ‘run_orchestrator’
…rver/town/orchestrators/craft_items_orchestrator.lua:221: in function ‘_collect_ingredients’
…_ace/monkey_patches/ace_craft_items_orchestrator.lua:122: in function ‘run’
stonehearth/services/server/town/town.lua:488: in function <stonehearth/services/server/town/town.lua:487>
[C]: ?
[C]: ?