aborted_frame radiant_policy_rethrow

I choose rayya’s children and the desert map. I picked an area with mountains on three sides and the foothill of the mountain. I’m playing a normal (combat) game.This is day 2 and I had just placed the potter’s brick oven. Here is the error.

release-489 (x64)
:aborted_frame:radiant_policy_rethrow
stack traceback:
stonehearth/services/server/threads/thread.luac:87: in function <stonehearth/services/server/threads/thread.luac:87>
[C]: in function 'fn’
stonehearth/services/server/threads/thread.luac:98: in function <stonehearth/services/server/threads/thread.luac:96>
[C]: in function 'fn’
stonehearth/services/server/threads/thread.luac:109: in function 'private_msg’
stonehearth/services/server/threads/thread.luac:168: in function '_dispatch_messages’
stonehearth/services/server/threads/thread.luac:128: in function 'suspend’
stonehearth/services/server/threads/thread.luac:146: in function 'sleep_realtime’
stonehearth/components/ai/ai_component.luac:187: in function '_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function 'xpcall’
stonehearth/services/server/threads/thread.luac:89: in function 'f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>

this is my computer specs with a asus mother board recently installed, since the mother board the computer came with was bad.

Ibuypower FR960X-1 Gaming PC with Intel Core i7-5960X 8-Core Processor,32GB DDR3 Memory,2TB Hard Drive + 240GB SSD Drive,Blu-Ray Combo Drive,Nvidia GTX980 Graphics,Liquid Cool, Windows 7.

I installed the Asus mother board before Dec 2015.

Can you reproduce the bug ?
Hello boys ! @moderators
And holy soap, where did you buy this PC beast ? :no_mouth:

I too have purchased a few rigs from these folks… very solid custom PCs… :+1:

4 Likes

I have nothing for this one. The log is doesn’t give me anything to go on, other than the fact it is likely AI related. Probably going to need @Albert for this one…

I got the computer at Fry’s last year. The mother boards that come with it are bad though.

I don’t know about reproducing the bug. It may have happened because I placed the potter’s brick oven too close to the mountain wall. I moved it away from the wall before I continued to play.

I kept playing the game and I haven’t had any more errors.

Right now in the game, the goblin’s mad but he hasn’t attacked me. Of course he can’t get to me sense I took away all the ladders. I’m getting ready to go after the goblin with my 2 level one footmen.

Good strategy :smile:
Alright, just have to wait for Albert to see that bug.

I have a save from when I first started the game, a save right after the error message, and a resent save, before choosing to not give the goblin what he wanted and one after playing while the goblin’s mad at me.

@Albert is the best person to tell you what to upload or information to give :wink:

2 Likes

I started a new game and did the same with making the storage under the mountain. I promoted a worker to mason. I told her to build her work station and went looking for her on the map. She was eating so I was watching her so that when she finished eating I would see her build the work station and then place it on the map. She froze in place, everyone else was eating and moving. Then I got the error.

Pic of her frozen in place.

removed

The error.

release-489 (x64)
:aborted_frame:radiant_policy_rethrow
stack traceback:
stonehearth/services/server/threads/thread.luac:87: in function <stonehearth/services/server/threads/thread.luac:87>
[C]: in function 'fn’
stonehearth/services/server/threads/thread.luac:98: in function <stonehearth/services/server/threads/thread.luac:96>
[C]: in function 'fn’
stonehearth/services/server/threads/thread.luac:109: in function 'private_msg’
stonehearth/services/server/threads/thread.luac:168: in function '_dispatch_messages’
stonehearth/services/server/threads/thread.luac:128: in function 'suspend’
stonehearth/services/server/threads/thread.luac:146: in function 'sleep_realtime’
stonehearth/components/ai/ai_component.luac:187: in function '_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function 'xpcall’
stonehearth/services/server/threads/thread.luac:89: in function 'f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>

I loaded the game after quitting it and she was able to move and built her work station.

Hey again @littlecats, it looks like you already had a report with this error! Good to have a bit more information though.

As a friendly reminder, please try and submit your reports to the Bug Reports category (or whatever category makes sense if not reporting a bug). Thanks!

Do you have the link so I can bookmark it? I can’t find the link on the bookmark I have.

Nevermind I think I found it under the support link.

Glad you found the link @littlecats. If you don’t want to navigate into the category every time, there is a nice drop down menu in the topic composer. Just click on it, and find the category you need!

2 Likes

Yes, this looks like a bug in the ai code. I’ll take a look. Thanks!

4 Likes

Thank you jomaxro! that’s very helpful.

1 Like

This style of error made it back in release-784(x64). Ill post the pics.
PC specs:
Win 7 64bit ult, 8gig ram, i5-3570 cpu @ 3.4Ghz, Nvidia GeForce GTX 1080. Game is on a 1TB drive

I just killed Ogo Skullbonker about 10 mins prior to this. Finished the purple outside walkway around my base. Finished the tree on top of the carpenter hut. Next I was clearing a group of trees near my base. The mods I have on are the better stockpiles and the terrain color mod in which I added more colors in the stone category. I uploaded the save file and the 2 mod files.


1518133705906.zip (7.5 MB)
terrain_colors.smod (34.5 KB)
better_stockpiles.smod (239.4 KB)