A23 Bug - Assertion Failed: GetSuspendKey(L)

Getting the attached error during combat.

Assertion Failed: GetSuspendKey(L) == suspendKey(C:\rb\ihome\root\SH-OB0-BUILD\stonehearth\source\lib\lua\ai\thread.cpp:134)

Steps to reproduce:

  1. Play game…
  2. I received the error while fighting the initial marauders during the Goblin War

Expected Results:
Error free chaos.

Actual Results:
An error in the chaos


stonehearth.log (459.2 KB)

Version Number and Mods in use:
A23 - Mods - lots

System Information:

Are you using mods that have custom AI or classes? The log shows an initial error caused by using outdated AI interfaces which triggered other errors downstream. I know at least the 22.5 versions of the Cafe and Archipelago mods suffer from this issue.

It may have been Archipelago although I didn’t really understand why it was attempting to read something from C:\rb\ihome\root\SH-OB0-BUILD\stonehearth\source\lib\lua\ai\execution_frame.cpp:982 which looks to be a hard coded path.

Also I have been seeing these. I will disable all my mods and see if I can reproduce.

2017-12-02 14:24:17.627117 | cef | 1 | browser | Load error: -3
2017-12-02 14:24:17.684125 | server | 1 | simulation.remote_client | started buffering client updates. (seq:309647 ack:309637)
2017-12-02 14:24:19.018921 | client | 0 | core.system | not tested C:\rb\ihome\root\SH-OB0-BUILD\stonehearth\source\game_engine\legacy_game_engine\horde_render_node.cpp 160
2017-12-02 14:24:19.027922 | client | 1 | lua.code | Shutting down script host.
2017-12-02 14:24:19.167939 | client | 1 | lua.code | Script host destroyed.

The path is just referring to the location of the source code when the game was built. It isn’t referring to your machine.

1 Like

Thanks for clarifying.

I’m getting this exact same error frequently for no consistent reason that I can see. I’m currently in release 771 vanilla with no mods. Quite often the error is followed up by an in-game error message (as below).

release-771 (x64)
Unknown C++ exception
stack traceback:
[C]: ?
[C]: in function ‘execute’
…ut_another_restockable_item_into_backpack_action.lua:69: in function <…ut_another_restockable_item_into_backpack_action.lua:50>
[C]: ?
[C]: ?
[C]: ?
[C]: ?
[C]: ?
[C]: ?
[C]: in function 'run’
stonehearth/services/server/tasks/task_action.lua:196: in function <stonehearth/services/server/tasks/task_action.lua:193>

[C]: in function 'run’
stonehearth/components/ai/ai_component.lua:515: in function <stonehearth/components/ai/ai_component.lua:499>
[C]: in function 'xpcall’
radiant/modules/commons.lua:66: in function 'xpcall’
stonehearth/components/ai/ai_component.lua:499: in function '_thread_main’
stonehearth/services/server/threads/thread.lua:273: in function <stonehearth/services/server/threads/thread.lua:270>
[C]: in function 'xpcall’
radiant/modules/commons.lua:66: in function 'xpcall’
stonehearth/services/server/threads/thread.lua:270: in function 'f’
radiant/lib/env.lua:15: in function <radiant/lib/env.lua:14>

I searched this error code on my screen and came upon this thread, @max99x . Not sure if this is the exact same issue. I do not run mods, never installed one.

I believe this was triggered by a glitched wall that I had my workers rebuilt. They started it and wouldn’t finish,\ the first time, so I deleted it and attempted to rebuilt it. They just began working, then this happened game crashed. I tried to save, hoping not to loose the few days I just played. To no avail tho.

Crocod00m save.zip (316.4 KB)

OS Name Microsoft Windows 10 Home
Version 10.0.16299 Build 16299
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Manufacturer To Be Filled By O.E.M.
System Model To Be Filled By O.E.M.
System Type x64-based PC
System SKU To Be Filled By O.E.M.
Processor Intel® Core™ i7-7700 CPU @ 3.60GHz, 3601 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. P7.10, 10/27/2016
SMBIOS Version 2.8
Embedded Controller Version 255.255
BaseBoard Manufacturer ASRock
BaseBoard Model Not Available
BaseBoard Name Base Board
Platform Role Desktop
Secure Boot State Off
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = “10.0.16299.192”
User Name DESKTOP-M84MODI\Kevin
Time Zone Central America Standard Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 7.95 GB
Available Physical Memory 1.18 GB
Total Virtual Memory 19.0 GB
Available Virtual Memory 8.52 GB
Page File Space 11.0 GB
Page File D:\pagefile.sys
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not InstantGo, Un-allowed DMA capable bus/device(s) detected, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

It might be this one:

I get the same error.

These modules are active in my game:

I got another bug that may or may not have a connection to this one:
co-routine failed: stonehearth/lib/game_master/game_master_lib.lua:114: root node entling_ritual_site not found
and it’s posted here: Error and then game halt\crash - root node entling_ritual_site not found

I’ve added this just in case there’s a connection ,If you don’t think there’s a connection just ignore. :slight_smile:

Assertion Failed: GetSuspendKey(L)== suspendKey(C:\rb\ihome\root\SH-OB0-BUILD\stonehearth\source\lib\lua\ai\thread.cpp:134)

I keep getting this error after a few days of playing and I never have before the update that made water flow!
Anyone have an idea of what is causing this???


Some bugs that could cause this have been fixed in A24 (which is currently on unstable).