[A20] The buildings my hearthlings will not build (round 4!)


#21

here a new template… 2 try : 0 building finished…
template : Dining.zip (71.5 KB)

screenshot :

here the example of the process :


Alpha 21 - bug destroy a building house not finished
#22

scaffolding doesnt get removed
maybe because of the touching buildings, save file:


building template
castle unf.zip (51.4 KB)


#23

Couldn’t find where to submit buildings that will not build so hope this new topic is aright.

Summary:
This design does not seem to build.
I’ve tried 3 times to build this and each time they get stuck.

Steps to reproduce:

  1. Play Rayyan’s children set up
  2. Palace this building and ask it to be constructed.

Expected Results:
Hearthlings construct the building.

Actual Results:
On two attempts they left a hole in the centre plinth. Hearthlings were trapped inside and no one could get in to fill in the central hole.
On one attempt they got round this, I think because one corner had scaffolding in the way of one corner so they filed the canter before they blocked it off. However one square on the roof was missed during construction. They would not build any way up to it so I manually placed a ladder. This did not spur them on to place the missing block. As a result the scaffolding was not taken down or any decorations, windows or doors were placed.

Notes:

Attachments:
building_templates.7z (52.0 KB)

Version Number andMods in use:
Alpha 0.22 (release 729) x64

System Information:
Windows 7, 26 bit.


#24

This building wont build to completion, it seems to be the windmill part that are causing problems?

eph. craftmasters guild hq…zip (37.1 KB)


#25

@moderators is there any way i can use for example the debugtool to locate the problem with my template? I dont want to scrap this template, but maybe modify it a bit to work if possible? :merry:

EDIT: and of course after 2 minutes i found the issue… but i still want to know if there is a answer to the question? :merry:


#26

For my first building of my new playthrough my hearthlings messed up on two things.
First off, they built way to many ladders as seen here.

And then secondly they wouldn’t take down the scaffolding once they finished.

I tried restarting, but that didn’t fix it.

Im not sure what else I need to post. I looked for the guide but couldn’t find it.


#27

The template for said building, would be good.


#28

hers the .json

https://drive.google.com/open?id=0B95QgG8FC1jMQldXdFFJU0dyeFk


#29

Another thing that kept happening was that when one hearthling was building another would move over from where they were building and work on top of the other hearthling.


#30

The same had happened to me, but with this template instead:


Inside that round short tower you see on the right, Hearthlings are supposed to place a Forge, but, of course, because they never removed the scaffholding, there was nothing they could do


#31

Yeah anytime the scaffolding is not taken down is because the exact block they need to remove next is not reachable. This shouldn’t happen in the new building editor (you can ask Chris next week, I think it’s his turn to stream at Twitch).

Thank you very much for the templates!


#32

Summary: So, when I have my guys build the prefab Clay Dining Room they are able to build everything except that last window. I have one in my inventory, they just won’t place it. See attached picture.

Steps to reproduce:

  1. Build Clay Dining Room

Expected Results: Clay dining room should be finished

Actual Results: Clay dining room is never finished because the last window is not installed. I waited several days and it was never placed. I removed the whole building and tried again 2 more times and the same exact thing happened.

Notes:

Attachments:

**Version Number and Mods in use: No mods and the latest branch.

**

System Information:


#33

Add a stair next to that old stair. They can’t climb it with the lamp in the way.