[A18/A19] The buildings my hearthlings will not build (round 3!)

You have to compress it, then upload the zip folder here.

here is a another one. I only seem to have trouble with 2 story buildings.
barn.zip (25.9 KB)

1 Like

Summary: There seems to be an issue with the blacksmith house not completing itself.

Steps to reproduce:

  1. I have a world.
  2. I create a blacksmith house.
  3. It doesn’t finish up as shown in picture. Gets stuck here.

Version Number and Mods in use: Latest version of alpha unstable branch on Steam. Vanilla Stonehearth

I would appreciate some help as the unfinished structure looks rather ugly…

Re: the Blacksmith House - FIXED - I have been having the same issue where the building will not continue after a certain point. I have tried building multiple times under different circumstances - area, rotation, removal of scaffolding, added ladders, etc. Nothing worked. However, after seeing the image that Relyss posted regarding the three blocks on the side of the small/lower roof section, I thought I would try editing the template before building. Upon removing the three blocks from each side of the lower roof, the build completed without issue! There is a conflict with the scaffolding and those three diagonal blocks on each side.

Also, something to note - inside the second flood of this building, there are 10 blocks in the corner (on the floor) that are not necessary and seem to be a bug or overlooked during development? I’ve always removed them when I’ve built this building.

I hope this helps!

XD

2 Likes

:persevere: Same here, I would build it and it would stop, then I instant build to fix it, and it only completes some of it and the hearthlings removes some of the scaffolding and leave the rest there. I then manually fix the scaffolding and ladders.
I noticed those blocks as well, not sure if it was a bug or intentional? :confused:

This windmill is not being finished in build 656 64bit. Relyss, in this thread, said it would get finished by placing some ladders in tricky positions. The savegame in which the windmill doesn’t get finished is in this thread too.

windmill.zip (22.1 KB)

Does this belong here?

Making a Tunnel type town and hearthlings will only lay the bottom layer of a simple 4x2 x 4 high slab wall, they have access on both sides.

1 Like

Hello there,

playing around with the editor, Alpha 0.18.0 656 x64

My hearthlings stops building, when they should start with the roof. I placed it anywhere, but always the same, they build it up to where the roof starts, stoping the work on it and that’s it …even a few decors and thing like chairs they don’t want to set.
I’m not getting any errors to this, they just stop the work.
The destroy button is working good.

best regards

maddahome for two.zip (11.5 KB)

1 Like

lighthouse.zip (10.9 KB)

Tried building this lighthouse. First 2 attempts the villagers managed to build the first 2 floors, then got stuck building the third floor. For the third attempt, I rotated the building, and they only managed to build the first floor, but then got stuck on the 2nd floor.

No villagers were actually stuck, they just stopped working on the building.

1 Like

Got some buildings, one is a custom castle and one is the blacksmiths hut, ascendancy town. they build half of it an then wont touch it.

I get this error message

release-656 (x64)
@stonehearth/components/ai/ai_component.lua:551: (1639263 stonehearth:squirrel) has not yielded after 10 ai spins. Are they in a bad state? Last abort reason: follow_path mover aborted reason: could not compute full path in start.
stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:456: in function 'verify’
stonehearth/components/ai/ai_component.lua:551: in function <stonehearth/components/ai/ai_component.lua:509>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
stonehearth/components/ai/ai_component.lua:509: in function '_thread_main’
stonehearth/services/server/threads/thread.lua:249: in function <stonehearth/services/server/threads/thread.lua:246>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
stonehearth/services/server/threads/thread.lua:246: in function 'f’
radiant/lib/env.lua:15: in function <radiant/lib/env.lua:14>

Whenever i load save

Welcome to the forum, @Zandramas44 :slight_smile:

The error you uploaded isn’t related to building, and it’s already known.
In this thread you can see the Blacksmith house has been already reported too.

Could you upload the template of your custom castle so the devs can check it?
In order to upload a building template:

  1. Save your build as a template in game.
  2. Open your game directory.
    Default location for a Steam install is:
    C:\Program Files (x86)\Steam\steamapps\common\Stonehearth
    Default location for a Humble install is:
    C:\Program Files (x86)\Stonehearth\
  3. Navigate to the building templates stored in \saved_objects\stonehearth\building_templates
  4. Locate the .json file for your template. For example, if you wanted to upload the “Clay Dining Room” template, find clay dining room.json.
  5. If you created this template in a recent version, you will also have a .png, for bug fixing purposes this is not important and does not need to be included in the .zip.
  6. Compress the .json file to a .zip file.
  7. Right-click the file you wish to zip.
  8. Left click Send to.
  9. Left click Compressed (zipped) folder
  10. Hit Enter on your keyboard.
  11. Upload the file to this thread in the Discourse by clicking the upload button in the editor and navigating to the file, or drag the file into the editor with your mouse.
1 Like

Summary:
I had started building the Blacksmith Town Template you unlock via campaign and hearthlings stopped working on it halfway through so I decided to ib the rest of it and just ‘destroy’ the scaffolding and ladders and now after starting my save back up I get this error Unknown #33501 | C - uPaste.me!

Steps to reproduce:
Irregular bug that can only be reproduced from a standpoint of a building that hearthlings abandoned

Expected Results:
No error

Version Number and Mods in use:
Alpha 18 Release-663(x64) No Mods
System Information:

Hey there, I got a new one to fix for you, yay :smiley:

Alpha 19 build 3181 latest dev build on 22.10.16
I’m trying to build this Deserttemple on top of a mountain, that might be an issue. But I didn’t find any place they coudn’t get to. And they managed to finish one of the four turrets. I made a few screenshots to show you guys, that’s easier, I guess.
Also, they finished the outer area without needing the ladders they wanted to place but couldn’t build. However, to be sure, I let them build these afterwards by placing a few more on the bottom of the mountain. But it didn’t matter, they still don’t like their temple :cry:

deserttemple.zip (32.0 KB)


Looking like this when the missing part is showing inside the building menu. Aaand I’m not missing any materials. There is also plenty of wood for scraffolding. Well, not plenty, but enough to continue building at least.


See, the first tower is nearly complete. Since they don’t start with another, I think the issue might be with this tower, but I didn’t find anything to fix it.


At first, they didn’t wand to build the stairs seen here inside the building either, but they did after pausing the building and turning it on again.


And that’s how it should look like afterwards.

By the way, I think it’s awesome that you actually try to fix every issue about this really comlex buildingeditor. That’s not really common for the gameindustry nowadays, see ubisoft and ea games for example :unamused:
Thank you for doing that, it really helps improving the game a lot :+1:

3 Likes

trying to make a dutch windmill. The villagers keep running up and down the scaffolting but can’t figure out how to build so they just stopped.

How it should look

template save
dutch windmill.zip (5.2 KB)

2 Likes

As always, as soon as a new Alpha arrives I try to let my Hearthlings build all of my templates and collect the issues I encounter.

All of these count for the latest build of Alpha 19 (0.19.0 release 687 x64).

2 Story house (2 beds)

  • last Window Frame on the first story right side is not placed, Probably because of the stairs. Can be fixed with placing a ladder outside left from the window
  • sometimes it get’s finished properly if scaffolding happens to be present long enough for a heartling to place the Window Frame

Carpenter House

  • Construction finishes
  • Items like lanterns, planters and so on wont be placed even though they are available

Compass Square

  • Stone Wall Lanterns on the roof won’t be placed. Can be fixed with adding ladders. Sometimes 1 or two lanterns get places if scaffolding happens to be still there.

Windmill

  • doesn’t get finished, stops after initial construction, last items won’t get placed

PS: Can we please be able to include ladders in templates? I have to manually place the ladders in the windmill after the construction finishes to make my Hearthlings able to place the items in the upper floors.

Mason House

  • Template can not be placed, only items like window frames, beds and doors appear, floating in the air

  • Trying to place the Mason Hause delivers this Error Message

    release-687 (x64)
    No matching overload found, candidates: luabind::object load_json(lua_State*,std::string const&,bool)
    stack traceback:
    [C]: ?
    [C]: in function ‘load_json’
    radiant/modules/resources.lua:33: in function ‘load_json’
    …/fixture_fabricator/fixture_fabricator_component.lua:361: in function ‘_get_rotation_tweak_xz’
    …/fixture_fabricator/fixture_fabricator_component.lua:436: in function ‘rotate_structure’
    stonehearth/lib/build_util.lua:562: in function ‘rotate_entity’
    stonehearth/lib/build_util.lua:566: in function ‘fn’
    stonehearth/lib/build_util.lua:172: in function ‘for_each_child’
    stonehearth/lib/build_util.lua:565: in function ‘rotate_entity’
    stonehearth/lib/build_util.lua:566: in function ‘fn’
    stonehearth/lib/build_util.lua:172: in function ‘for_each_child’
    stonehearth/lib/build_util.lua:565: in function ‘rotate_entity’
    stonehearth/lib/build_util.lua:580: in function ‘restore_template’
    stonehearth/services/server/build/build_service.lua:1616: in function ‘build_template’
    stonehearth/services/server/build/build_service.lua:1607: in function ‘cb’
    stonehearth/services/server/build/build_service.lua:1582: in function ‘do_command’
    stonehearth/services/server/build/build_service.lua:1606: in function <stonehearth/services/server/build/build_service.lua:1604>

After this message, I can’t place any new templates. I stopped testing any other templates after this.

The save game as well as well as my templates are attached to this post.

won’t build A19.zip (56.0 KB)

3 Likes

tower.zip (4.4 KB)

Alpha: 19.0
Build release: 687 x64
I like to call this one “The Unbuildable Door” - the rest of this tower will complete, but I am left with partial scaffolding and a missing door (no matter how many of said doors I have in my town inventory).

I’ve been trying to build this tower for a while in this town, and my hearthlings will complete much more complex structures - but not this pesky door!

2 Likes

Alpha 19,
687 (x64)
no mods

not a custom building.
The clay dormitory that comes with Rayya’s outpost templates will not complete. Everything finishes and the scaffolding removed, but the final window (front rightmost) never gets placed. tried building multiple times.

Hello, it’s been a long time since I’ve played Stonehearth, so I decided to see how it has developed. A lot of progress has been made, it has become quite a complete and engaging experience.

I came across the problem, however, that when building the Rayya’s Children version of the Forge prefab, it never completely finishes. It gets to a certain stage of construction, where all of the blocks have been placed and all of the windows installed, but not the door, forge, anvil, or lamps, and then the hearthlings pull down a bit of the scaffolding and just stop. I tried putting many ladders around the building, which sometimes works when the hearthlings get stuck building things on the edge of cliffs or some such. Then I thought that maybe the area was too crowded for them to access some parts, so I placed the template out in the open a couple of times. However, whatever I tried, construction always stopped at the same place.

I don’t know if this prefab has been successfully constructed before, but for me, in this build, it seems that the prefab itself is the source of the problem.

I had a similar experience with some custom buildings. They got constructed completely, except for one final object. In most cases, this was a door. The missing object was in my inventory, though. Sometimes it helped to order a crafter to manufacture one more entity of the missing object, which was then placed and the building finished correctly.

Welcome to the forum, @Bickler and @Alfalfa :slight_smile:

In this case (the forge), the hearthlings should have finished removing the scaffolding, and they didn’t, it is a bug.
I have no problem with the Clay dormitories, though. Do you have a savefile where the problem is happening, @Bickler ?

1 Like