A16 Assertion failed: random crash


After reloading and playing a savegame for ~4 minutes, the game suddenly pauses and a Windows error message pops up:

“Assertion Failed: header.compression == COMPRESSION_NONE(C:\rb\ihome\root\SH-OB0-BUILD\stonehearth\source\lib\voxel\qubicle_file.cpp:67)”

Then the game crashes to desktop.

I’ve tried to figure out why this happens, but all i could find out was something about a compressed file in a mod, which is funny because i don’t use mods.





Versions and Mods:

A16r559 vanilla (x32)

System Information:

Win 7 Pro 64bit (SP1)
i5 6600k
GTX 750Ti

+When starting a fresh game, i can play for 2-3 hours without any crashes, but after that the game crashes every 4-8 minutes. I had this problem for the first time when i updated to A16 , A15 worked without any issues.

+I also noticed no particular pattern that could be the cause of the crash. It seems to be random.

+I am currently running the game in 32bit mode because 64bit will result in a BSoD when crashing.

+Sometimes i am unable to save and the savegame thumbnail gets deleted. Idk if this could be connected to my original problem, because the game will also crash after 2-3 saving attempts.

i too have been seeing more back to desktop crashes after the release of alpha 16. an increase even with the latest small updates. Not sure if it is connected, seeing i never had error message with it.

Right, I’ve only seen that assertion on the forums when related to a bad qubicle file. Usually when people tried to mod, and they used the wrong export settings.

Maybe @not_owen_wilson knows of other possible reasons.

Thanks for the attachments, @KastorSF, and welcome to the forum :slight_smile:

1 Like

I have seen this in other error reports and I do not know what it means.
KastorSF, stonehearth.log

has these entries. the game is trying to process the critters attribute (thinking they are there?) but not finding any critters.
would this lead to an assertion error? The critter such as the Racoon has an entity id of 2267632 so something has to exists, yes/no?

2016-05-29 14:17:25.383000 | server | 1 | mod stonehearth.attributes | [] Trying to recalculate attribute: muscle on entity: (2267632 Racoon) but there was no attribute data

2016-05-29 14:17:31.563000 | server | 1 | mod stonehearth.player | [] no population for player “critters” in :is_npc()


+ I’ve changed to x64-mode and started the game without Steam.
Since then i’ve played for 8+ hours without any crashes or bugs.

- If i start via Steam /32bit-mode the same crashing happens again.

Are there any known issues with Steam crashing the game?

1 Like

have you try’d reinstalling it? So not just uninstall but remove all files and then do a clean install?

Yes, i’ve tried that multiple times without success. But 64bit mode seems to be working for now.

1 Like

There were times when the 64bit version gave problems, but now it is recommended if your computer can run it, because with 32bit version you might end up having memory issues. Not sure if this is still valid nowadays, though.

People having crashes when playing with Steam is not unheard of, but I don’t remember the workaround for it.
Maybe searching in the Crash report category could give you more hints.
We had a topic for crashes because there was a time when lots of people started having crashes due to third party software:

But in your case only crashes when you run it from Steam, so I don’t know :sweat: