~20 seconds into the game crash


A couple of seconds into the game it freezes and never recovers. Music keeps playing on for a while but that stops too in under 1 minute (20 30 seconds less more who knows)


stonehearth.log (4.4 KB)


There is no such file https://i.imgur.com/ujBR0IB.png

Versions and Mods:

v1.0 r898

System Information:

Windows 10, gtx 970, Desktop monitor

Have you attempted basic troubleshooting steps here: Crashing on start? Read this! UPDATED October 18, 2016

Yes, it leads to crashing in max 30min as well even if it does work. (i am against the network stuff cause it resets my apps configurations and i can’t do that every time i want to play, if it is the case)


Get your shit together really, I fiddled with it long enough cause i really want to play it but it clearly is broken

:thinking: by “the network stuff” you mean the resetting ports workaround? Looking at your log, that shouldn’t be the case here. However, I wouldn’t discard the need to add an exception for the game (and for the crash_reporter.exe) to your antivirus / firewall (if it’s Windows Defender, add them as a “Process”, not a “File”), but perhaps you already tried that.

You’re using the unstable branch with no mods which plenty of users have no problems with.

We’re still investigating the crashes since we have trouble reproducing them. We caught one recently, but it happens with an unreleased mod so we need to figure out whether it could be the same type of crash that some players are experiencing or if it’s caused exclusively by that mod.

Some players managed to fix strange crashes by unplugging external hardware such as webcams, footpedals to talk, or headphones/mouse that had faulty drivers, but I doubt it’s your case here too. Some had a bad Windows or RAM installations, but that’s going too far.

Did you try running the Stonehearth.exe logged out of Steam? Sometimes Steam is the problem, it could happen with any game.

Did you try running in 32bit mode? It’s an option within the System tab of the game settings (you can also edit the user_settings.json to force the 32bit version to run). If you’re able to run with the 32bit version without problems, then the culprit is a 3rd party application (likely related to security).

netsh advfirewall reset

netsh int ip reset c:\resetlog.txt

netsh winsock reset

Theese things from here Crashing on start? Read this! UPDATED October 18, 2016 i mean by “THE network stuff”.

Regarding external devices and browsers, could it be a USB sound card? It seems to be working properly and i have no problems using it, but it is a bit old.

I’ll test the sound card and reply again.

1 Like

I just logged out of steam and ran it from the game dir, it seems to be working. I’ll shall now proceed testing it more thouroughly, and i’ll be back if it misbehaves. How should i go with modding if steam is causing the problem? (i was using it to subscribe to stuff)

Yes, I meant those.

You can also install mods manually inside the Stonehearth/mods directory. If you had already downloaded the mod, you can find the subscribed mods inside C:\Program Files (x86)\Steam\steamapps\workshop\content\253250

So if you really need to use a mod from the workshop while logged out from Steam, you can copy its individual folder from there (although it’s difficult to figure out which mod is which, but for templates it should be easy since there will be a building_templates folder inside) and paste it into the Stonehearth/mods folder. However, it won’t get updated if the modder updates it, since the updates go to that Steam workshop folder.

Later if you open the game with Steam open it will say you have conflicts since you’d have two mods with the same namespace enabled at the same time, but unchecking one and save+quit to main menu should fix it.

Still crashing, tried 32 bit too, do i repost the log?

Yes please. You’re not using any mods, right? Was this time with or without Steam?

Without steam, no mods

stonehearth.log (12.7 KB)
crash.dmp (132.1 KB)

It appears we have a crash too now, i attached it

1 Like

According to your log, you managed to load a savefile. I wonder if it’s that savefile what is crashing? Does it crash on new games or other savefiles?

If it’s only that savefile, could you upload it too? Instructions just in case:

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

Odd, there was no save, i specifically went and created a new game. Maybe i sent something wrong? I don’t even have the save directory

My bad, I probably confused the logs since they’re similar (load progress, it was likely the load of that game, not necessarily from a savefile).

The crash.dmp mentions something about not having permissions to read/write, which is strange since I can see at least the animations and saved_objects folder were created. :thinking:

I am getting a feeling regarding this. Let me check real quick

Allright so thing is i got 4 hdds and some weird restrictions because how my windows reinstalls were not clean, but i didn’t have problems other than accesing system folders sometimes so i just backed up and let them sit since its on my oldest hdd and whatnot. Now steam was in program files, also a folder that while doesn’t lock me out, it asks for permissions to do stuff which is weird since i am indeed the admin. I thought it might have been from here so i put the steam library in C:\Games

Tried it a couple of ways starting from standard latest build 64bit install with steam and now 32bit steam logged off it stayed a little more but still crashing. Here’s the logs

crash.dmp (115.3 KB)
stonehearth.log (6.3 KB)

Anything on this? My photoshop crashes similarly as well so i will most probably do a complete wipe soon in the near future.

Inspecting your last crash.dmp, you have one of the conflicting libraries from the “crashing on start” thread.

It’s something called Bonjour, if you could uninstall it (or disable it, but some apps reenable themselves on their own) and try again?

It went a little longer this time, like 3 - 5 minutes, but it still crashes with not responding.

stonehearth.log (28.8 KB)
crash.dmp (121.3 KB)

It was worth the try, sad that it didn’t help much :disappointed_relieved:
Can’t find anything else suspicious in the log / crash.dmp. We’ll keep investigating since there are still players with crashes like yours.

Let us know whether it still happens or not whenever you wipe your computer and reinstall your programs. I wonder if it still has something to do with drivers or some library (since you say your photoshop crashes similarly too).

:frowning: i hope it gets sorted one way or the other, i can’t wait to dig into all the new content and mods, will let you all know how the wipeout goes

1 Like