Yeti's Mod (adding yetis of course)


#1

Hi i’m Yeti and I just started working on a basic mod to add baby yetis as critters. I was wondering if anyone knows how to export .json files from blender, thanks. (I will continue to evolve this mode as features in Stonehearth are released).


#2

I think this is pretty accurate:

It was by none other than @voxel_pirate of these very forums! It was created to help modders like you!


#3

Man, he got to the link before I could! I hope to see this awesome mod you’re talking about! Will this be it’s own race by itself or just creatures?


#4

Oops, didn’t see that, thanks!


#5

no worries… good luck on your Yeti mod! do you want to leave this thread open as the home of your mod, or …?


#6

@SteveAdamo Could you leave this open as the home of my mod (and other things I make)? Thank you.


#7

@Yeti TUGenius already posted a link to a video of the Stonehearth Add-On. The easiest way will be using that one (it supports export of skeleton-files / rigs and animations).

Here you can find a thread related to the Add-On in the discourse-forum:

And here is the homepage with a manual:

http://www.stonehearth.de/weblog/blender

Just let me know if you get stucked.


#8

I’m not really sure what is wrong… my game freezes every game after a little exploration (I think it is when the yetis load) and then only lets me pan the view… I did fix one error though…

I’m also not entirely sure on how to link to files…(by my next post I will probably have figured out a way…)


#9

That looks like you are refering in one of your files to an alias which is not defined in the manifest.json. Can you explain what you did (step by step) to get your models in?


#10

Hey Yeti! :smiley: Lovely idea for a mod! :slight_smile:


#11

Here is the link: Dropbox - Error
@voxel_pirate , I exported the skeleton and animations all from blender (I used on blend file and just set the start and stop frames though…) My StoneHearth now won’t even start with this file in the mods folder (never actually did though, I was modding the stonehearth.smod file before… oops).


#12

Unfortunately I cannot open the zip-file as my system claims it is not a valid file.

Can you explain how you’ve included the files into Stonehearth? There is obviously no Yeti yet in the game… so you’ve simply replaced another model (if yes, which)? The error message looks to me like one of the .json-files is including code similar to “stonehearth:yeti_baby”, maybe trying to load the animation or skeleton.

Solving the issue might be as easy as changing this line to “yetiMod:yeti_baby” (as the yeti_baby might be defined in your mod, not in the Stonehearth-mod)… but it really depends on what you are trying to do.

Can you try to open your zip-file… maybe it is not only me.


#13

Just took a look at your files myself and I think voxel_pirate is right you need to reference your manifest not stonehearths this is what I have done for my mod. Also I noticed a spelling error in the manifest "stonehearth/scenarios/index.json": "yetiMod/scenatios/index.json"
needs to be scenarios not scenatios.


#14

oops, thanks @The_M, also thanks @voxel_pirate, I will fix both of those issues.


#15

Ok, I made it a folder this time: Dropbox - yetiMod
I also tries making it so I didn’t have to completely recopy the index.json file, and tried to fix all the errors and make everything point to the yetiMod file that should…


#16

Well, probably won’t be part of the mod …I’m still not sure what is wrong with it… But here is Mr.Monster :

and animated: