Workers Outfit causes bug

When the mason wore the “workers outfit” it got bugged and he is not producing nor can change class.

Also, promoting a new mason wont work either.

So got stuck in the game cause mason cant produce anything.

Btw i bought the worker outfit from the traveler.

1 Like

Welcome to the forum, @grkmori :smile:

I believe the mason shouldn’t be able to equip a bought worker outfit. Starting by its class. Worker outfits should only be worn by workers, did your mason really equip it?

Either it’s a bug related to bought outfits, or due to the outfit itself / or the mason that shouldn’t be able to do that. :confused:

So weird…

The image missing:

OK… sorry.The outfit is probably because changed to worker and again changed to mason. (probabbly another bug).

It wasnt the outfit. Tested a little more and the conclusions is that i dont know what causes the bug.

In the game after some time mason stopped working. I couldnt identify the cause, It probably is not related to queue. Tried most of the things in the queue but it still bugs. Tried start the same map again but the same thing happens after some time. Tried another vilager to start with mason but same bug. From what I could check it is also not related to the change of the days (and add a new worker),

The thing is that the Mason stops working as a Mason and starts taking tasks of a normal worker after some time.

Probably is something related to Mason’s ‘work Bench’. Take a look at this second image:

After trying to to change professions my mason starts to spawn infinte Mason’s tools. It happed in both games that got this bug.

here is the link for the saved game:

1 Like

Oh no, it’s that bug again :cold_sweat:
I think it’s related to demoting, but there might be other things that caused it.

The mason not working on his queue it’s a different bug, and has been already reported (crafters prioritizing non-crafting tasks).