Water stress test (from new version)

So I tested the new water. It looks like it is faster? Feels like it is.

But then it failed, no errors shown though.

The image describes what I did.
I did some random holes.
Then I dug both green channels in the picture.
After they complete it, I started digging the orange channel.
When they mined the first block from that mine region, marked in the red circle, the water popped up (?) and flooded the sand area for some reason. It can be seen that the water spread in a circle area with its center at that first block mined.

Here the save file:
shift_f5_save.zip (1.7 MB)
The text log: stonehearth.zip (19.5 KB)

Hope it is useful for your quest on fixing the water @Albert


Ill add my test to your thread Bruno, so it is collected at one place :slight_smile:

I tried out the waterfall part of the water and there have certainly been some improvements, but here are some screenshots of a few issues and the savegame aswell.

EDIT: @Albert this was a new game just for testing the water out. :merry:

Sorry for the nighttimeshots, but i am in a bit of a hurry :slight_smile:


watersavegame.zip (4.7 MB)


So…digging out a lake…I kinda accidently the whole thing. Upon dropping the water level below a minimum, I now get a new white…foam? Also, in some areas, the water will “evaporate” like it’s supposed to, while other areas it still remains the top layer like it used to.

Couple notes:

  • Frames drop to almost unplayable as soon as this happened.
  • Just letting it run causes the “evaporation” to spread, but even a save/load doesn’t remove the “foam”.

Save Game (3.4 MB)

So to give a final update, after letting it run for a while, it finally finished and the game returned to normal. As for the “evaporation”…it’s taking it’s sweet time but I guess it’s doing it.


Thanks for all the bug reports. When reporting a bug about water, let me know if this was a new game created on Alpha 22.5.2, or if it was a save game that you loaded.

Also, if anyone has specific steps that can reproduce any weird behavior that would help a lot.


May be a stupid question, but is there a way, or a chance of a way being added, for us to add water to specific areas to create new tests for it?


So I started a new game, with the same map, repeating the same steps.

  1. Start map 801871163.
  2. Harvest trees around lake.
  3. Begin squaring off lake by digging 2 voxels deep.

Ended up getting an error with crash this time, where as last time was with a previous save.

Save Game (2.8 MB)

1 Like

@SirAstrix I tried a few times to reproduce the error without luck. Do you have any other hints about what order of operations causes it to occur?

Honestly no. All I did was mined the top individual layer of dirt, then the one underneath it that had water flowing after they had finished the top layer. After loading that save and working on another area, I didn’t get the error, but instead got a couple more artifacts like the one shown next to the Hearthling.

And to make things funnier, I decided to reload the other save file that had been a previous 22.5 save, and the water is working better in that save than the new game.

Only other thing, but I doubt it would effect it, is that I’m running Home Sweet Home.