Undefined UI errors

Had two undefined UI errors, one on 27/8/2016 and one on 28/8/2016
Steps to reproduce:

  1. I don’t know what caused the first error, (it is possible that the same template was the problem) but the second one occurred when I placed a particular custom building template.
  2. Place template
  3. Get error
  4. Press F5
  5. Placed template again and no problems

Expected Results:
Building to be available in ghost form
Actual Results:
Please see uploads for the two errors

I tried to upload the template (Json file) but the page would not permit this, so picture only attached.
Version Number and Mods in use:
18 3109 x64 No mods
System Information:

Windows 10 Home
Intel core i7 -2600 CPU@ 3.40GHz
16 GB ram
64 bit operating system
Nvidia Geforce GTX 750 Ti

UI bug 27082016.docx (13.2 KB)
Undefined UI error.docx (12.8 KB)

for upload place it in a zip file. My guess s that if f5 works and you don’t get it again it most likely is nothing serieus. Did you build the template you wanted to build in an older version or did you just designed it?

I kept getting UI errors when placing a custom building build in A17, discovered I had the terrain mod and used a block or two from it and A18 won’t accept it.

1 Like

Hmm if you’re playing A18, you should download the latest terrain mod and delete the old one, I’ve updated it over the weekend.

I’ve not tested if old templates would work, but I think they should, since I just changed the api version of the mod.

1 Like

I tried to zip the file and got an access denied message. I tried copying the file to desk top and then zipping - still no joy.
The template is one I created for the current game. I have two similar templates. I tried to build the original template again after posting and had a ui message again so it is something in the templates that the game doesn’t like. The hearthlings gave up part way through so I built with ib. Here’s a picture of the red roofed version after decorating.