Unbearable Stuttering [A18] (ROG Gamefirst Service)

Hello, after a long hiatus. I’m back… and so is one of my issues.

After I got my awesome new ASUS ROG laptop, I’ve pretty much been unable to play Stonehearth. I run it at a perfect 75 FPS (according to the Steam overlay; it never goes higher than that for any game so it may actually be higher) but no matter what I did, the game stuttered horrendously. It would be fine for anywhere from 5-15 seconds, then freeze for one or two, then be fine again.


If the ROG Gamefirst Service is the source of your problem as described above, if you end the task using the task manager it will turn back on the next time your computer shuts down/restarts. Unless there is a workaround to keep it permanently off (aside from uninstalling the service), it will keep coming back and must be ended through your task manager.

hey there @MyCoal417,

first off i’m going to page @Albert for you, as he’s a dev and a lot better with the performance stuff than myself. getting your specs again would definitely be good. hmm… do you have any security programs that could be messing with things?

also, in-game whats going on? is it just every brand new game has this problem, or is it only on old saves?

(sorry, been awhile since i helped with performance stuff, i’m a little rusty :grimacing:)

edit: oh! could you also provide you .log file?

This sounds like an Intel HDxxxx in action :stuck_out_tongue:

@8BitCrab Here are the specs:

Windows 10
Intel® Core™ i7-4720HQ CPU @ 2.60 GHz 2.59 GHz
16.0 GB RAM
1 TB Hard Drive

The computer came pre-loaded with McAfee (which the free trial for has since expired and it is very obstinate about reminding me every thirty minutes), and I don’t have any other type of anti-virus/malware program installed… which I probably should change.

And yes, every brand new game has this problem. It doesn’t matter how I change anything in game, there is still lots of stuttering.

Here is the Stonehearth.log file: http://dumptext.com/lyQZaKuj

It really sounds like either another graphic card trying to get in the middle, or (most probably) another application messing with the game. Try disabling McAfee even if it’s just the reminder, and make sure that the game can run despite your firewall or other default security applications from Windows.

Have you tried running the game in other modes (windowed / fullscreen, 32 / 64bit…)?

1 Like

I haven’t tried mcafee in years but was it possible one of these program still running, despite being told to shut down?
if it’s expired anyway you should just remove it entirely.


This could be any program that’s monitoring network packets or some security software (maybe even extensions?) that injects itself into the Chrome browser. ROG Gamefirst is at the top of my list for this behavior (which you’ve already disabled).

If you’re at a complete loss, maybe dump the list of processes running from task manager to see if anyone can spot a possible suspect.


@Relyss I haven’t tried switching to 32bit, so I’ll see if that’ll help. I’m going to completely uninstall McAfee, beyond that how would I check how it’s running against firewalls?

@Albert Anything specific I should look for, before I do just dump it all here?

edit: 32bit actually made it a whole lot worse, lol

It’s hard to be specific. Anything on this list would be a good start, but as Albert said:

I had some stuttering in 18, when I would get to 28ish people the game would stutter every few seconds, not game breaking but noticeable. Since I’ve been on 19 I’m up to 35 and haven’t noticed stuttering yet at all.

I know this may not be the most helpful, but 19, even the unstable is very improved on performance.


Ok, well, it seems that I was wrong about ruling out ROG Gamefirst… when I opened the task manager, I saw ROG Gamefirst Service (32 bit) running, even though it’s turned off. I shut that down and now it runs smooth as ever.

Thanks for all your help, and I’m sorry this turned out to be an oversight because I was lazy/superficial in my persecution of ROGG and ended up wasting time. :confused: At least the problem is solved, so I guess that’s a plus!


no need to apologize mate, we’re here to help after all (though i may or may not have missed your last @mention of me… :eyes: ) glad to see everythings working again, if you run into more problems don’t hesitate to report!

will mark as Res

1 Like