Trying to host a MP game

Interesting error when trying to host instead of joining a game:

release-832 (x64)
Uncaught TypeError: Cannot read property ‘playerId’ of null
TypeError: Cannot read property ‘playerId’ of null
at getPriority (http://radiant/stonehearth/ui/game/multiplayer_menu/multiplayer_menu.js:267:15)
at http://radiant/stonehearth/ui/game/multiplayer_menu/multiplayer_menu.js:277:34
at Array.sort (native)
at n._updateClientArray (http://radiant/stonehearth/ui/game/multiplayer_menu/multiplayer_menu.js:276:15)
at changeCallback (http://radiant/stonehearth/ui/game/multiplayer_menu/multiplayer_menu.js:150:18)
at http://radiant/stonehearth/ui/game/traces/presence_client.js:90:22
at Function. (http://radiant/radiant/js/radiant/object.js:305:19)
at Function.each (http://radiant/radiant/js/external/jquery-2.1.4.min.js:2:2936)
at Object.radiant.each (http://radiant/radiant/js/radiant/object.js:303:15)
at Object. (http://radiant/stonehearth/ui/game/traces/presence_client.js:88:24)

Mods all turned off for this attempt

Steps to reproduce:

  1. Turn off all mods; create Multiplayer game
  2. Pick Ascendency, put them in the forest, go through the usual, plop down, pause, invite other player to join.
  3. Get error message after sending invitation.

Expected Results:
Inviting @Wiese2007 to join me for a multiplayer session. Likely laggy at best, given my notoriously bad internet…

Actual Results:
Wiese does not make it into the game, likely getting the same error I have been when trying to join people (see below)


I am not exaggerating about how bad my internet is.


Version Number and Mods in use:

Multiplayer Super Unstable
Debugtools (all other turned off for test)

I have same problem when I tried to join others game. :glum:

Question that might be informative, what did you do with the max players slider,?

I set it to 2; Wiese had tried hosting one for me to join previously, was my turn to try. Since it was just the two of us testing, I didn’t see any reason to set it higher


Do you happen to have the stonehearth.log from the failure to host the game?

The UI error should be easy to fix (I think) but we’d like to know if there was something bad happening in the background. Bad connection could have been an issue, but it could also have been something else.

stonehearth.log (56.8 KB)

As it happens, this should be the right one - I haven’t turned the game back on since then (as I’ve been plugging away at mod json files instead)


Additional log, from me being unable to join someone else’s MP game:

stonehearth.log (18 KB)

1 Like

Took a brief look at this. The first one is either a timeout issue (see the keep awake setting in the MP thread - this is fixed in the next release), or something to do with mods. You mentioned that you have all mods disabled, but the log is referencing mods. The second one looks like it might be an antivirus or firewall blocking your connection.