The Stonehearth Graphics Test Thread

Let me guess, you have FPS which are around 60, right? I have the impression that the FPS are capped this time.

To be completely fair, I’m guessing it’s lower than that.
I haven’t used a program or anything to see what the fps was at the first test and this one… But the decrease in FPS is actually visible…

good catch… its possible that there may still be terrain optimizations, or optimizations in general, that are still being applied… its also possible that the graphics test might not be capitalizing on available optimizations…

or, i could just be trying to say optimizations as many times as possible in one post…


Actually I hope this isn’t fixed. I want to be able to scroll through trees. The main reason being fighting in dense trees. You don’t want to have to reposition your camera everytime you encounter a tree.

Bit more Z-fighting where tree intersects with mountain terrain - Example screenshot

Most clouds are still quite fast moving, fine for just watching but might get distracting for gameplay

CPU levels dropped from 90-95% down to 15-20% on i5-2500k (base clocked)
Memory levels nice and low still - added less than 200MB of ram use
Graphics levels ~30% during windowed mode (75% of screen) upto ~55% full screen, down from 80-90% on windowed mode on test 1 - AMD 7850

Otherwise running nice and stable
CPU: i5-2500k
Graphics: AMD 9850
Memory: 16GB @ 1333
OS: Windows 8.1


thanks for the feedback… i tossed a duplicate of your post in the associated bug report

feel free to “like” the report, and/or add any other information you can provide there…

1 Like

How are you seeing the FPS? I didn’t see any option for it, but iirc it was supposed to show it right? Also, the 2nd test didn’t ask me if I wanted to send the data, did it do that automatically this time round?

You don’t see them unless you have a tool installed like FRAPS which shows you the FPS.

Yes. In the news to the download it is mentioned that the program is sending data as the first test did. Seems like the option was removed:

“Just as a reminder, we are still, with your permission, collecting anonymous crash and performance-related data…”

1 Like

I have done roughly 30 minutes of active investigation (plus 30min of playing around with my son who wanted us to play it…). Recorded a short video of my impressions.

The biggest issue I had was that the framerate seems to jump between 30 and 60 fps if I have v-sync turned on. If I change the setting I will still be around 60fps most of the time, sometimes higher and sometimes lower, but it never locks at 30fps as it does with v-sync on. I can see it with Fraps overlay fps monitor. Sometimes I can switch between 30 and 60 just by zooming one step out and in.

some Z-fighting on trees for example, nothing new. Jagged shadows, sometimes really visible jagged in certain angles. Nothing new on those though. I’m not happy with the camera and its movement, I would actually prefer to have the zoom focus point always in the middle, and move around the screen with keyboard or mouse combo. But camera implementation is still early, I know that.

Regarding camera within objects I personally prefer it to make objects completely invisible if camera is inside them. Alternatives are as it is today with only certain parts invisible, or camera automatically moves in front of the object, but I know from certain games that it can be really annoying if it occurs to often.

Here is a short video with explanations and details:

edit: I wasn’t sure if v2 bugs should go in a new thread or a separate for each report. Feel free to move in that case :wink:

1 Like

I have a 7850 2 GB and i5 3470 and only get 12 fps. 1600x900 res.

I’m afraid I had the same issue as before with this new graphics test despite my hopes. The program installs fine, then when I try to execute the program a window pops up, moves slightly to the left, and then closes without giving any error report either when the window closes or in the Stonehearth folder.

My specs again:
CPU: Intel Core i3-2310M @ 2.10 GHz
Memory: 6 GB
OS: Windows 7 64-bit
Res: 1366x728
GPU: Radeon HD 6490M + Intel HD Graphics

I will be trying again on the other computer to see if this new test has fixed the more common error it had.

The one problem i have, albeit a small one, is that tree leaves are merging and creating a lovely glitch graphic. Other than that, all seems to be going very well.

I’ve got the same issue.

Processor: AMD A6-3650 APU with Radeon HD Graphics 2.6 GHz
RAM: 8.00 GB
Windows 7 Home Premium SP-1 (64-bit)
Graphics Card: NVIDIA GeForce GTX 550 Ti

Error in the Event Viewer:

Product: Stonehearth – Error 1308. Source file not found: C:\Users\MyName\AppData\Roaming\Radiant Entertainment\Stonehearth\install\8EA456E\Stonehearth.exe. Verify that the file exists and that you can access it.

When I go to look in the folder, all I see is install_stonehearth.msi, no stonehearth.exe. That folder will start populating with stuff when I run the installer, so I can see it loading up folders and files, but it stops prematurely each time.

Getting an Error when i try to start it up its says:

Microsoft Visual C++ Runtime Library

Runtime Error!

Program: C:\Users\Vaughn\Desktop\New folder\Stonehearth.exe

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application’s support team for more information.

Please help!

have you tried “running as admin”? can you take a look at your logs at the time of the crash?

Try installing Microsoft Visual C++ Runtime Library. But make sure you look up your issue to make sure this will work for you.

1 Like

just notice that there was a graphics test, downloaded and tried to launch but nothing happened, no window or anything, only noticeable change is that my cpu usage went up by 10% of a second

so far ive tried, reinstalling, restarting computer, running as admin, drivers are updated

however im not sure whether doing so causes its own problem but when i try to run the game within the sandbox of my antivirus, a completely isolated environment that i can run programs with no risk to my computer

i get this error

Problem Event Name: BEX
Application Name: Stonehearth.exe
Application Version:
Application Timestamp: 529e37d4
Fault Module Name: StackHash_0a9e
Fault Module Version:
Fault Module Timestamp: 00000000
Exception Offset: 46eff761
Exception Code: c0000005
Exception Data: 00000008
OS Version: 6.1.7600.
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

again im not sure if this is caused by running it in the sandbox or a problem from elsewhere

Have you tried using Google to see if you can find a way to fix it? But I wouldn’t worry about it because the Alpha is about to come out in a few weeks. So, you could try to fix this now or wait till the Alpha comes out and hope the same error doesn’t happen.

all i got from google was uninstalling kb/2670838 a windows update of some sort but i dont even have that on my computer

another one said that stackhash has something to do with my OS

also tried installing microsoft visual C++ runtime library as another one suggested, nothing working so far

i certainly hope this will no happen when the alpha is released

What OS are you using?

What are your specs?