Templates broken in the new alpha?

I’m trying to re-build my Maratas fortress in the new Alpha (a few things I wanted to do differently) and when I try to re-place my old templates, they don’t work. Instead I get the following error message:

develop-2940 (x64)
No matching overload found, candidates: luabind::object load_json(lua_State*,std::string const&,bool)
stack traceback:
	[C]: ?
	[C]: in function 'load_json'
	radiant/modules/resources.lua:33: in function 'load_json'
	.../fixture_fabricator/fixture_fabricator_component.lua:333: in function '_get_rotation_tweak_xz'
	.../fixture_fabricator/fixture_fabricator_component.lua:401: in function 'rotate_structure'
	stonehearth/lib/build_util.lua:410: in function 'rotate_entity'
	stonehearth/lib/build_util.lua:414: in function 'fn'
	stonehearth/lib/build_util.lua:58: in function 'for_each_child'
	stonehearth/lib/build_util.lua:413: in function 'rotate_entity'
	stonehearth/lib/build_util.lua:414: in function 'fn'
	stonehearth/lib/build_util.lua:58: in function 'for_each_child'
	stonehearth/lib/build_util.lua:413: in function 'rotate_entity'
	stonehearth/lib/build_util.lua:428: in function 'restore_template'
	stonehearth/services/server/build/build_service.lua:1485: in function 'build_template'
	stonehearth/services/server/build/build_service.lua:1476: in function 'cb'
	stonehearth/services/server/build/build_service.lua:1451: in function 'do_command'
	stonehearth/services/server/build/build_service.lua:1475: in function <stonehearth/services/server/build/build_service.lua:1473>

moonphasemosaic.7z (17.2 KB)
Tower of the Moon.7z (55.8 KB)

And they won’t place even on flat normal terrain. Any fix possible? Hand-engineering those again would be prohibitive.


Adding @not_owen_wilson, in case he has any insights. Unfortunately, he’ll be out for the next few days.


Hrm. It doesn’t work any more even when I revert to the prior beta build. Maybe it’s because I switched to Windows 10? Aaarg/

All my other templates work, just not those two.

1 Like

Well, that was very strange. Whatever it is, I managed to fix it by loading an earlier savegame and resaving from the in-game copy.

1 Like

I can confirm this. Several custom templates do not work with the current unstable build. Not sure why, but when I try to build them it won’t let me and just gives a similar error message to yours. You were fortunate if reloading fixed it. Most of my templates work just fine, just not my barracks and armory ones.


I had to go waaay back to savegames from the prior alpha build, where the building was still just an in-place draft ghost, and resave from that placed ghost. I tried it a few times with different saves before I got one that worked.

Ok, update:

I spoke too soon.

The moonphase mosaic template did seem to fix itself, but the tower doesn’t work and doesn’t build correctly (they try to build the top first OR I get an error when the tower is placed, especially if I rotate it).

It also seems to rotate “off center” for some reason – the rotation point isnt the central axis of the tower.

moon tower.zip (50.6 KB)

1 Like

minaret.zip (58.5 KB)

I ended up re-making the same tower “from scratch” and this version works. It also uses an obscene amount of wood purely for scaffolding (roughly 500 units).

1 Like

It seems for me that the ones that I can’t place are the ones that don’t have a png file along with them (no pic next to template name in-game). I can’t even see the outline of where I’m going to place the building. I’ve only done this in alpha 17 so I can’t say for sure if it’s a bug only in the new alpha. @Hieronymous I run windows 8 so it probably isn’t the fact that it’s windows 10.

Edit: Re-building (starting from scratch) the building and then saving the new building seems to work for me as well.

Edit 2: Nevermind, placing the building doesn’t work. Although, I do get the outline of where I’m going to place it.

1 Like