Template: Builders not finishing the building

I created a template, and the workers have nearly finished the building, but they are not taking down the scaffolding and placing the doors and lights.

All the items were added in the template creation process and nothing changed during the building.

I have tried adding the items manually, but instead of saying that the item has been placed according to the template it just puts the item over the ghost template and still requests an identical item to be placed in the same spot. Any idea’s how to fix? They have been standing around idle for 3 game days, so I am not sure what to do next.

Here is a picture of the building in a nearly finished state, they wont do anymore work on it.


You can ignore, the problem was that the building was too close to the cliff edge. I solved the problem by moving it 4 squares away from the edge.

I’ve found that often adding ladders down the cliff and up to where the building is is often enough to get workers to build a building on the edge.