Taking Questions about Mixintos and Overrides


rp_test_world [size=20]+[/size] zzz_rp [size=20]+[/size] rp_silence [size=20]=[/size] :+1:


Minimized window?

That’s… not default behaviour now though, is it? That sounds extremely like rp_developers_dreams

zzz_rp is part of RP (-rp, rp, zzz_rp) and does nothing/wrong stuff alone… You might want to try switching rp_test_world with rp_developers_dreams too.


Glad it worked, though if you have a suggestion for how to better word it, I’ll update the post.


yes, if you play fullscreen, the game minimizes when you start it. Not that it is a big thing, it is just a minor annoyance :smile:

yes, that will be it.

It does not specifically mention that it is the last file name that relates to the same json name. So adding a sentence that describes that would be useful imo.


Oh, that. That’s… RP’s fault, I’m afraid. I could fix that by not using dir and instead rely on a binary module or something like that. It’s likely something that will not happen with the next RP. For now, however, I recommend playing in windowed mode…


Sort of unrelated question: How does “region_collision_shape” work?

I’m trying to create a a piece of furniture that is 1 voxel tall, 10 voxels wide and 20 voxels deep and I’m trying to allow them to be place-able into this type of pattern:

I’m using the colission shape from the picket fence:

"region_collision_shape" : {
         "region": [
               "min" : { "x" : -1, "y" : 0, "z" : -1 },
               "max" : { "x" :  1, "y" : 3, "z" :  1 }

Now when i build the furniture and place it short end to short end they fit nicely but when you try to place them short end to long end there is a decent sized gap between them.

Any help would be appreciated :smile:


That is because the collision shape does not rotate together with the object when you rotate the object. I had this problem too with my stairs.


Well this ruins my plans for adding this type of furniture in my next update. . . . :frowning:

Any plans on making collision shapes rotate with the object? @sdee


Thanks for bringing it up! I had not realized they didn’t rotate. Hmmm…

Well, at least now it’s on our radar! Feel free to make a bug :wink:


Okay will do after I do more testing. :slight_smile: Also were the original debugging tools removed? I tried to activate them but kept getting an error when I tried to load the game. Apparently the font in notepad was allowing me to mispell “enable” the five times I tried it. . .


I recommend Notepad++, it spellchecks AND you can set it to lua/json and it’ll highlight keywords. Very useful :wink:


I still have no clue on how these collision shapes work but I’m not sure if that’s the issue. I don’t quite see how they even play a part in the placing of objects, as I can place two tables over-top of each other.


Collision shapes prevent people from running through objects.

Actually I’m not totally sure how the collision shape is affecting your original problem :stuck_out_tongue:

Can you put in a screenshot or diagram of the gap?


I guess I was only assuming that was the issue. lol

Well time to ruin the surprise:

Somewhere I thought I heard that one game unit was 10 voxels, so that’s why I made the porportions 10 x 20.

The idea is to make them place able in the orientations in that diagram I posted a little earlier


Tatami! ) So awesome.

Hm… is there any space around your .qmo?

The world does have a square grid, and objects are indeed scaled down from qubicle to 1/10th their size by default. Oak Logs are 9x9, but their qubicle model is 10x10. So yes, models that are 10x20 ought to tile.

I would try making 10x10 square blocks and see what happens when they rotate, to help figure out where in the process the (literal) disconnect is happening.


The matrix is the same size as the tatami

I figured that was the case. I scaled the file in qubicle to 20x40 and now they are closer but they overlap by one and are off by one voxel.

I’m wondering if maybe qb file is a little off-center:


When I was working with my train tracks, they were 16x16. I’ve set the render_info’s scale to 1/16th (i.e. 0.0625) and it worked fine without overlapping (one track per tile), including rotations. But then again, I didn’t bother with collision boxes.

What happens when you have them odd numbered, i.e. 21x41?


They were. /facepalm

After fixing that they work. (and i found out i need to increase my graphics lol) :smile: I love to make all the little silly/stupid mistakes like this. :fearful:

At least it’s interesting to learn about these things though? :blush:


indeed! can’t learn/improve without trying first… :+1:


Is it possible to override something that isn’t in the mods folder?
Something such as the thought_hungry.png and thought_sleepy.png?